EDIT YOUR PROFILE HERE

Please or Register to create posts and topics.

Laser not turning off

Was wondering if there is a setting to turn off the laser? Mine is still engraving where it shouldn’t be will upload a picture

Uploaded files:
  • 3EAA4AF4-ECAA-4697-97F2-B18B25076A90.jpeg

Hi Riley,

This could be due to interference - could you please provide a photo showing your MG installation and the wiring to the power supply? Some users have put varios power cables on/near/under the MG or its PWM line and this is a major cause of this problem.

Regards,

Dan

Here is a photo

Uploaded files:
  • D252C682-FC81-4A42-A990-A4B122299FD1.jpeg

Hi Riley,

Ok thanks for the good photo.

See the yellow wire in the bottom right of the photo (PWM), that's the wire that controls the laser signal. So, you need to keep that as far away as you can from the blue wires, the big looping red wire, and especially the bundle of wires stuck to the bottom of the K40 with the adhesive standoffs.
I'll let you use your imagination at to how to do it, but anything non metallic like cardboard that you can bend/fold into a stand to separate the yellow wire from all the other wires will make a big difference.

Let us know how you go, maybe send another photo.

Cheers

Dan

riley1234198 has reacted to this post.
riley1234198

I cut thin strip of aluminum foil and wrapped the wire seems to help

Uploaded files:
  • E3FB63CF-4804-4547-9659-0FA5599C06B4.jpeg

ok, I've never seen it done like that before!

Better results are probably due to a combination of moving the wire away from the others, and your screening efforts.

Anyway, please let me know if you're happy with the performance you're getting now. Thanks

I've been having the same issue. I've tried moving the wire, moving the board, shielding the wire, shielding the board, it sometimes gets better or worse but never goes away. $32 is definitely set to 1.  I've checked all the power connections are tight and snug, there's strong continuity on the LO wire.  I've put the water pump on a separate power connection, and I run the air assist of my main workshop airline, so I've eliminated them as sources of noise. The only idea remaining to me is maybe a pull-down resistor on the PSU's PWM input?

My laser isn't a K40, it's a generic red/black 6040, and I saw mentioned in another thread that there might be a firmware issue, is there a fix for this yet?

Uploaded files:
  • IMG_20210421_153758008.jpg
  • IMG_20210420_185030692.jpg
dancolwp1974 has reacted to this post.
dancolwp1974

Hi Luke,

Thanks for the photo.

The two fundamentals of turning on a K40 laser beam are:

  • The LO signal - The LO signal must be active for the beam to turn on, and,
  • The PWM signal - The PWM signal is the strength of the beam. The greater percentage of the time that the PWM signal is on, the stronger the beam.

Lightburn turns on the LO signal at the start of the job, while the laser is moving. So I'm pretty sure that the diagonal line you're seeing is created the first moment you start the job, yes? Assuming this is the case, what you're seeing here is interference on the PWM while the gantry is travelling to the start of the job.

I can see the brown PWM wire is traversing over a cable tray, inside of which is the wires for everything including mains power and much more, so that's your source of interference. You could try taping some aluminium foil around the cable tray for, say, 10cm either side of where the brown wire traverses it. The other thing to do is elevate the brown wire as far above the cable tray as you can, for example by putting something non-conductive in between - a piece of plastic or wood.

From the photo orientation it looks like you could move the MG towards the bottom of the photo, so that the PWM wire is crossing straight over, rather than crossing at an angle over the cable tray.

Now what happens if the diagonal laser beam line is created at the end of the job? At the end of the job, Lightburn should have disabled the LO and so it's not supposed to matter what signal is on the PWM. So in this case, interference is causing the LO line so stay activated. I can see your light yellow LO line snakes around, then enters the cable tray (with all the other wires) before emerging and going into the K40 power supply at terminal L (L for Low, meaning enable the input when the signal is low). Wait, but what's that I see? A mysterious grey wire also going into the L terminal? Why would we want something else to be controlling the Laser - that's the Mini Gerbil's job! So please look into what the grey wiring is, and remove it so that there's one less source of interference.

You haven't mentioned grounding of the overall K40, so that's the other important thing to do.

In our experience the 'laser on' problem comes down to some kind of electrical interference like I have outlined above. The latest firmware version implements some changes in relation to PWM and LO that may help, but I urge you to consider that as a last resort because it's clear from the photo that there's plenty of pick up from nearby wiring that should be improved anyhow.

Similarly I urge you to improve the wiring before you resort to installing resistors. If you do want to go down that path, you could try a pull DOWN resistor on the PWM wire (because there's no output with a 0V signal), and/or a pull UP resistor on the LO (Laser Enable) input (because it is active low). Start with 100k resistor, see if it makes a difference. If not, try 50k, then 20k values till it starts working.

Regards,

Dan

So I've tried a few things, ultimately to no effect. Here's where I'm at now:

-I moved the MG down so the PWM and LO lines can be perpendicular, as recommended

-I put in the little archway to lift the wires up and over the cable tray to keep them away from it

-I covered the cable tray over with tinfoil for shielding

-The grey wire on PSU LO was a leftover still connected to the M2 control board, so I took the board and all its wires out completely

-I moved the secondary PSU over, this allowed me to route some of the AC wires over the top of the laser PSU away from the MG altogether, so they're not running  in that cable tray any more, they're as far as possible from the PWM/LO lines

And... sometimes better, sometimes worse, but no fix.

As regards grounding - I've got 1.5 ohms between the laser PSU G and FG, 7 ohms between the FG and the ground screw at the back of the machine, and negligible resistance between the screw and the naked metal of the frame itself. I have a dedicated wire running from the ground bolt to mains earth.

My next move was going to be updating the firmware but having looked at the release notes I'm not sure there's anything in there that might address this problem.

Due to the intermittent nature of the problem I'm very much inclined to think it's a hardware/interference problem but is there any chance it could be software related? I'm using Lightburn.

What's the likelihood that it's a problem with the PSU itself, rather than the controller or the wiring in-between?

 

UPDATE: I reinstalled the M2 Nano and it runs fine, so I don't think there's any issue with the PSU.

Uploaded files:
  • IMG_20210427_163104942.jpg

Hi Luke,

great photo, your archway and tinfoil are 'over the top' but in this case that's appropriate. I can see you've listed quite a number of changes, it's a little difficult to follow them all from the changed photo angle. This laser layout looks challenging because it appears the 24V line (and 5V line too?) incoming into the Mini Gerbil is snaking in from some distant location off camera - not sure what it's exposed to in terms of upstream interference.

Sorry one simple thing to try (I thought I wrote it previously but looks like I didn't) is to change the 5V jumper position, see https://awesome.tech/mini-gerbil-with-optical-end-stops/ That at least makes less use of the (potentially noisy) 5V from the power supply.

With that possibility covered, we may be in 'spending money' territory (which I realise is a bummer):

Assuming you don't have a programmer and you'd need to buy one for a firmware upgrade - I'm confident the problem isn't a 'software only' problem - there's too many other units out there with identical software that operate 100% fine, so there's some element of hardware issue in this problem somewhere. Note that this statement leaves the door open to the possibility of recent firmware tweak being able to overcome whatever the interference issue is. Essentially the tweak resets the PWM level to zero when no output is intended, rather than assuming the LO is operating free from interference.

There's been other forum posts where interference has been overcome by installing a mains line filter. Do you happen to have a mains line filter you could try?

I completely get your point that you can get the M2 working, so there's clearly something here Awesome.Tech can own up to. If you'd like to contact me directly, happy to work with you to sort out something mutually agreeable that'll get you up and running.

Regards,

Dan

the main change between the pictures aside from obvious is that the secondary power supply, which is in the bottom left of the original picture, is now off-picture towards the bottom right. There are AC connections between it and the laser PSU so moving it over allowed me to run those cables in the opposite direction, away from the PWM. That's where the MG's power connections are coming from.

 

I will try adjusting the 5V jumper. If that doesn't work I'll get a programmer and try the firmware upgrade. If that doesn't work I'll investigate getting a mains line filter. And if THAT doesn't work - I'll PM you.

Paul has reacted to this post.
Paul

Forum Registration

EDIT YOUR PROFILE HERE