Please or Register to create posts and topics.

Overlapping shapes and text

Installed new mini gerbil 3 MG3 board on my new Chinese co2 60w laser which had Moshi board and its own software which was cutting and engraving fine .
Downloaded the latest version of lightburn trial as the MG3 supports light burn and tried few cuts of circle ,noticed every time i click start , the circle is overlapped slightly , i tried playing around current / user and absolute coordinates , i see every time i tried the circle is either overlapped or starts cutting 1 below the other. i chose circle to make it easier.


Also the homing makes a huge noise though the limit switches are working , tried the old board , all are fine ( homing , cutting , engraving etc ..)


back to the mg3 and  all the issues starts , along with shrunk Y characters at times.

deleted the device added again , still same.




Uploaded files:
  • lightburn-overlap.jpeg
dancolwp1974 has reacted to this post.

Hi Jayan,

I can't see your Lightburn image, so not exactly sure what pattern you'd laid the circles out in.

The description of 'shrunk Y characters' is very helpful. If it was happening all the time then it could be an incorrect value in the $ settings, but because you say 'at times' it sounds random, in which case here are some common causes:

First thing to do is to check your Y belt tension, is it tight? If so, please reduce the tension slightly via a screwdriver (access from rear of K40) and re-test.

A few basic checks:

  • Please confirm you're not sharing the USB line with any other device (for example, a USB camera via a USB hub)
  • Please check there's no mechanical obstruction. For example, I have been caught out by a drag chain interfering with the inside hinge of the K40 case. Is there any physical contact of the gantry with something else?

If the above are all good, then you can try giving a *little* more current to the Y axis motor. We set the motor current to give enough power for a typical Y K40 axis weight, but larger machines like a 60W have a bigger heavier gantry and may need a bit more power to the stepper. The following link shows how to increase the stepstick settings for the previous model MG2, but it's very similar. See https://awesome.tech/adjusting-stepsticks/



Hello Dan,

Thank you for your reply .

1) The below circle is not a pattern but justa single circle whith multiple passes .
2) Now i see the X oriantation is wierd as a single object of single pass is cut 1 above the other eeeek . What i notices is , if there is a smaller ( say X30 mm and y 30 MM )object the single pass is fine , if there is a larger object or more number of object then we notice the objects are cut one over the other , eg if i have a X line of circle , square , triangle , rectangle , hexagon etc , all of them are cut one above the other .
3) There is no issue with belt as if i replace the Moshi bord the cut and engraving are just perfect without any grinding noise or jerk.
4) I had it connected to PI to access it wirelessly then i connected to USB directly.
5)There are no Mechanical obstuction as the same is fine if i replace the moshi moard.
6) I did try that as well, i did not notice it was going much wierder , earlier it was Y axis issue , but now we see the objects are cut at random places ... 🙁

Is there any firmware that am missing which the board might need ?


dancolwp1974 has reacted to this post.

Thanks Jayan.

I don't know what you mean by '6. I did try that as well'

It seems it's an intermittent problem called 'skipping steps'. It relates to the mechanical loading versus the available power to run the motors. There is definitely not something that a firmware upgrade can fix - you already have the latest firmware.

As I mentioned the MG3 is primarily designed for the K40, but with your larger gantry, you will need to turn up the stepstick power to ensure the motors consistently operate. Could you please go ahead with the guidance at the link below and advise the results?


Some further actions/questions. 

  1. Please confirm you haven't accidentally turned on Rotary mode in Lightburn
  2. Please advise any nearby equipment that could be causing interference (compressor, chiller, motor)
  3.  Please include a photo of your machine, and the gantry measurements. To my knowledge, the above link to increase stepstick output has worked well for 60W machines, but for a very heavy gantry you may need an external stepper driver such as a TB6600.
  4. Please advise what speed you are operating at when the issue occurs. Does it also occur at half that speed?

For simplicity of communication, please respond with the same point numbering.

Meanwhile, I will read your separate post with your $ settings and see if I spot any issue.



Forum Registration