Please or Register to create posts and topics.

No movement using minigerbil with lightburn

Good morning, I bought a used k40 last year that already had the mini geril and lightburn, when I went to use it last (a couple of weeks ago) and when I turned it on I did not get any movement on the gantry, I can take my finger and push the home switches and the software is happy but using the arrows or the home button in lightburn causes no movement.

The mini gerbil light does stay on. A second light flashes when first turned on or reset.

On a side note when I first got the machine, if I moved the gantry by hand very fast with the K40 off the led's in the k40 would light up. Since I have been trying to troubleshoot this I have noticed it is no longer generating power and lighting up when I move them.

sidenote #2 I hooked the original K40 controller back up, And when I power the machine on both axises move to the homing switches perfectly.

Hi Matt,

Sounds like a few things going on. Let me check I understand:

  1. Everything was working when you purchased it.
  2. Using the arrows or home button causes no movement. This could either be a homing, software, user or hardware fault - you haven't explicitly said whether the gantry moves when you run a normal cutting/engraving operation, could you please spell that out?
  3. The green light is a general 'controller is getting power' light. Ignore the red light that flashes for now.

Sending electricity to a motor causes it to move. And vice versa, moving a motor causes it to generate electricity. The faster you move the gantry, the more electricity it generates. I've never heard of a user manually moving the gantry very fast, and the electricity this would generate could well damage electronics. Hopefully the damage is limited to the replaceable stepsticks. You should replace the A4988 stepsticks (which are quite cheap) and adjust their pots to the recommended positions, see https://awesome.tech/adjusting-stepsticks/



Thanks for the reply Dan!

1 = yes

2 = yes/I dont think I ever tried to force a program to run, with it refusing to home or move  using lightburn it generated errors and I assumed it would not run a program.

3 = I figured as much just wanted everyone to know it was getting power.

I just placed an order for new step sticks on eBay I assume these have to be soldered in?#imnotreallyanelectronicsguy.

On another note, if it matters I can hook the OEM board up and run programs out of k40 whisperer.

Again I really appreciate all your help!

Ha, ha, I've never seen #imnotreallyanelectronicsguy  ... kinda wonder whether that's trending on insta as they say...

Don't worry, no soldering required, just pull out the old units by hand and carefully plug in the new ones. The link I sent last post should make it clear but by all means reach out if unsure.

You're welcome.

okmatt has reacted to this post.

Well I put the new step sticks in and adjusted them like the post you linked, still no response. Do you think I need another gerbil or what are the odds of a wrong setting in lightburn? Somewhere on his forum I found default settings for the min gerbil. Is there a way that I could paste all these into lightburn and eliminate that possibility?

Hi Matt,

sorry there's no way to bulk-copy and paste $ settings, but it only takes a few minutes to enter $$ into the console, and compare row by row to our page listing standard values at https://awesome.tech/what-are-settings/

If no joy from that, please contact me privately and I'll work through how we best get you lasering again.



Thanks for the response. I'll compare them before buying a new board.

Forum Registration