Please or Register to create posts and topics.

Light and power switches analogue

Sorry, only logged-in users can see spoilers.
Hi, Can any one tell me where the wires from the stepper switch go. I have converted to analogue from digital and steppers will not move, laser works OK.  There is nothing showing these or where they go. Many thanks


Uploaded files:
  • 16310234303222535002584278076087.jpg
  • 1631023606545285180738917245232.jpg
  • 1631023655518262803962617198877.jpg

Hi Mike,

I've never heard of a 'stepper switch', and the photos look like an it's an older model k40?

If you've plugged in the stepper motor cables directly to the Mini Gerbil, the former wiring to the stepper switch shouldn't do anything.

If you have a multimeter/voltmeter, are you able to confirm that 24V is getting to the controller?

Also, please send a photo of your installed Mini Gerbil controller board.




I call it a stepper switch because I turn it off to move axis by hand? Any way followed your article regarding changing from digital to analogue, laser fires as it should but motors do not move. I did look through the article again and saw in a photo that you have not used this switch. I have 24v at the PSU going into the mini gerbil but no movement on steppers, no power is getting to them. I am using Lightburn, the K40 is about 3 months old. Attached some photo hope you can understand them as I am no electrician!

Uploaded files:
  • 16311072143914229850658639855301.jpg
  • 16311072895835489556524310701002.jpg
  • 16311073350285884052520666441951.jpg
  • 16311073786851227332579257041050.jpg
  • 16311074114465562428542154967904.jpg
  • 16311074327528937531518731204681.jpg
  • 16311074876447179527882283980813.jpg

Thanks Mike,

I noticed your main white plug doesn't look too secure in the last photo? If you can ensure that's 100% seated onto the board, like this image, then we can discount the connection as the cause. If you need to push firmly to seat the plug onto the board, please put a wooden spoon or similar underneath while doing so, to support the board so it doesn't flex.

If it still doesn't work, please email me directly and I'll organise a replacement.




Uploaded files:
  • Fully-seated-plug.jpg

Hi Dan, tried to clip it in as suggested but it will not go. What is your email? Also G+ has been taken off google now and a few of your links are to G+

Hi, I have had an ongoing problem with my stepper motors not working. I have had to replace the PSU as it went pop. I have the new PSU installed but no power to steppers.

I have 24v going from PSU to Mini Gerbil board but nothing coming out to the steppers.

Any ideas would be welcome thank you


Hi Mike,

So I take it that you've checked the grounding after installing the new power supply? Also, I recall from our email correspondence you at some point had two connections to the IN terminal, so hope that's been fixed too.

Sometimes motors don't operate because a stepstick has failed. I understand you have some spare red stepsticks available... Could you please try swapping them over? Always good to take a photo before you pull them out so that you install the replacements with the same orientation.

Please carefully read the following post so that you ensure the 'pots' are set correctly on the stepsticks you insert. https://awesome.tech/adjusting-stepsticks/



Hi Dan

Thanks for getting back to me. Yes the ground goes from the psu to the chassis and then out to a metal stake into the earth

The two wires in the IN terminal are the PWM lead from the board and a connection from the power turn switch, I removed the amp meter wire and no change apart from amp meter did not work

I did change stepsticks and have just looked to see if they are set correctly which they are

I have 24v going from PSU to the board and virtually nothing coming out of x or y terminal only  .9 mv to about 3mv but, I am not sure what wires to measure across

Would this have any bearing or am I taking the reading wrong?




Forum Registration