EDIT YOUR PROFILE HERE

You need to log in to create posts and topics.

K40 board does not have ribbon cable

12

Hello all, my k40 does not have a ribbon cable. It does have another connector populated on the end of the board.  Any help here would be great. Not sure what to plug where and the instruction pictures for the connectors is super small and when you zoom in they are blurry and unreadable.  What should I do to get this connected?

Same issue and I have two motor control plugs.

Uploaded files:
  • 20171216_173313.jpg
  • 20171216_173325.jpg
  • 20171216_173339.jpg

Hi, from the pictures I can see some labels gnd, xl, yl, gnd, nc. I assume there is also a 5V hidden behind the wires and not visible in the photo. I speculate that these labels mean ‘ground ‘ (minus),’ x axis limit or endstop’, ‘y axis endstop’, again ‘ ground ‘ and ‘not connected’. These connections are available on the k40 shield as separate connectors next to the big 4 pin power connector see photo below. Just read the matching labels on the k40 shield or if you have trouble to get the picture in your head then i will draw a diagram for you.  You don’t have to cut off the connector but buy some 12v splice auto connectors. These slide over the wire and let you connect another wire. You need a few dupont or also known as arduino female connectors. Good source is mouser or digikey or otherwise any tandy or radioshack type of electronics store. In Australia we have jaycar and they sell 4 pin female connectors for about 65ct (aussie) each. You can find these via google i.e ‘hm3404 connectors’:

http://www.jaycar.com.au/4-pin-0-1-header-with-crimp-pins-2-54-pitch/p/HM3404

amazing to see that there is a 4th version of K40 out there. Everyday I discover something new about these machines. It seems that the machine is being manufactured by many tiny factories... ok keep me posted how it goes. Anyone who has wired it up, please post pictures. Thanks

Uploaded files:
  • 8E1F52B8-BF97-407F-BEAE-139344317A35.jpeg
  • E672AD1C-FB9A-4673-A355-CC0727AA662C.jpeg
Cheers, Paul awesome.tech

Paul,

I think this is what you were getting at?

Uploaded files:
  • greensingle.jpg
  • 5VJUMP.jpg
  • 20171217_111002.jpg

x

Uploaded files:
  • 20171217_111002.jpg

Hi that looks really well wired up, nicely done ✅

I have the same set up as you.

When turning the Gerbil on, do we see the head home, or do anything?

Mine just sits there fixed in place, you can't manually move it.

I'm not sure if this is correct wiring.

 

I try the inkscape test - from the video - (after installing pyserial) and just get errors returned from inkscape.

I'm using a mac.

This is my wiring - does this look right?

Uploaded files:
  • wiring.jpg

Hi Lee, that looks great to me. Do you have electronic or mechanical end/limit switches?

Mechanical limit switches only uses x or y and gnd. Electronic limit switches such as hall and opto couplers require also 5v for their function.

cheers, Paul

Cheers, Paul awesome.tech

I have the same K40 version, no ribbon cable. I hooked it up, works good so far ( some stepper stall over 150mm/s I need to figure out..) in Lightburn. Only issue is no laser control at all...

Im a bit of a moron, but I didnt see in this thread where there was a solution posted for bypassing the ribbon issue..

Uploaded files:
  • GRBL.jpg
  • PWM.jpg

Hello Sevrance, just out of curiosity, did you connect the single (pwm ) wire supplied to the IN on the power supply and the first pin on the gerbil?

There is a 3 conductor plug, labeled g, IN, 5v , right next to the 4 conductor plug on the right side of power supply, the middle wire ( IN ) is the one you want.

Alternatively, use a SPDT on/on toggle switch so that you can switch between Gerbil PWM and standard control. I personally used a DPDT switch, and attached LEDs to the switch for visual evidence of which one was on.

My two cents,

Thanks gmonsey, I missed that somewhere, that got it working.

I have a K40 laser with no ribbon. I have attempted to connect the Gerbil control board as noted above, but not having any luck. The laser carriage locks and no laser fire when the machine is turned on. I put the laser back to the original configuration (no Gerbil) and it's working correctly. I'm not a programer, so many of the instructions might as well be written in Greek. Not sure what I'm doing wrong. The images attached are my current configuration. Any help would be greatly appreciated. Thanks

Uploaded files:
  • IMG_20180910_170109827-2.jpg
  • IMG_20180910_170046460-2.jpg

Hi, there is a good description on wiring this in this post https://awesome.tech/k40-forum/topic/k40-board-does-not-have-ribbon-cable/#postid-593

Next to this I realise that a lot of people don't understand the behaviour and think it is a fault.

The motors don't lock up, they keep the carriage in position so it does not lose its coordinates when moving around and stopping occasionally.  The setting $1=255 keeps the motors powered in zero motion state. You can alter this to lower numbers or 0 so it does not get powered all the time as configured by default. Advantage is you can move the gantry by hand, disadvantage is that the machine might crash because the position has changed without Gerbils knowledge. More advanced controllers do have encoders on their steppers so it knows via feedback that its position has changed. Alternatively you can add two more limit switches on the axis so it prevents that crash.

Please let me know if you get any further with it.

 

Cheers, Paul awesome.tech
Quote from Paul DeGroot on September 13, 2018, 6:49 pm

Hi, there is a good description on wiring this in this post https://awesome.tech/k40-forum/topic/k40-board-does-not-have-ribbon-cable/#postid-593

The link you provided only takes me back to my original post.

12

Forum Registration

EDIT YOUR PROFILE HERE