Please or Register to create posts and topics.

Fast Red Flashing LED


The board has been working fine without issue for months, Today I stopped the K40 mid-print as the burn wasn't quite how I wanted it.  Normally I have to right click devices in LightBurn to reset the K40 but that didn't work for some reason.  Restarting LightBurn didn't fix it either.  I Opened the door to see the board to notice the flashing red LED.  I checked the USB cable to make sure it hadn't come loose, but that was ok.  I then found the post


So I followed the instructions there but that didn't work for me either.  Tried another cable, drivers etc.  The PC detects the board when you plug it in and installs the windows driver but its not seen LightBurn.

When I first installed the board, it worked with the FTDI drivers that install as an option.

I tried to re-run the wizard but the board wasn't found.

I'm not sure what else to try.

Uploaded files:
  • board-flash.gif
  • 20210523_135326.jpg
  • 20210523_135355.jpg



For anyone else looking at this issue.  I rolled back to 0.9.20 of lightburn fixed the issue

Thanks Anthony,  i will investigate and see if there is a fix for it.

Cheers, Paul awesome.tech

Forum Registration