EDIT YOUR PROFILE HERE

Please or Register to create posts and topics.

error code 9 (end stop)

12
hello, I have a problem with the mini gerbil received today for my K40 laser. the end stop of the X axis is not found by the machine. I chose the top left corner as the origin but when I launch a return home the X axis motor continues to run, forcing even when the zero point is reached. there is no problem with the Y axis. I thought it might be a disconnected cable and to check I reconnected my original nano card and it works perfectly. is there a setting to make so that my end stop X is recognized? sorry for my english, i'm french and go through a translator. thank you.

after another day of testing I still can't get the machine to work and 
I'm going to end up damaging the k40 by forcing the motors that hit 
the chassis. I thought I bought a card made for the K40 but it seems that 
it was not made for the k40.I think there must be a problem in my GRBL 
parameters, here are some screenshots of my parameters, do you see a 
problem? I will not spend weeks torturing my mind for something that does 
not work, if I do not find I will contact the seller and paypal to return 
the card and I will save money to buy a card designed for the K40 .
Uploaded files:
  • config1.PNG
  • config2.PNG

Hi Vicent,

 

My apologies for the late reply but Dan is snowed under with running Awesome.Tech while I am moving interstate.

If you are not happy then you can return the controller (shoot Dan an email on dan@awesome.tech) and he will refund you when he receives the board.

The x axis end stop is probably not connected. Best way is to use the question mark command in the gcode sender or lightburn console and read out the limits while positioning the gantry in various positions (zero and non zero).

question 1: do you have a ribbon or a non ribbon version?

If you have a ribbon cable then the ribbon might not be positioned straight. Some ribbon cables are slightly out of spec since the K40 is manufactured my many factories in China. Pull the ribbon cable out and reinsert it carefully.

In non ribbon variants you need to check the connections and whether the limits are mechanical switches or electronic (they require 5VDC).

Question 2: Do you have mechanical or electronic limits? Electronic are those with an opto coupler.

This forum has many examples of the wiring and connection layouts, so please have a bit patience and use the search facility to look them up since I'm using a mobile hot spot today.

If everything works out then you might need to use a multi meter to measure the voltages across the limit switches.

Dan wrote also a blog about the limit switches which might be helpful see https://awesometech1.wpengine.com/limit-switches-and-homing/

Please let me know how you go.

Cheers Paul and Dan

 

 

Cheers, Paul awesome.tech

Another post about the topic that will help you to debug it.

https://awesometech1.wpengine.com/k40-forum/topic/identify-non-ribbon-cable-limit-switch-connections/

Cheers, Paul awesome.tech
good-morning Paul,
I have a version with ribbon and opto sensors. 
the sensor probably works because when I connect the original card on the 
machine the carriage leaves in its position and does not hit the chassis. 
here is a video that i just made or we see the functioning of the 2 cards, 
with the nano it works and with the mini gerbile the carriage bangs in 
abutment. I want to be patient but it's been three days that I tear my 
hair out of this problem and that I can not find a solution. there may be 
a hidden solution somewhere on the forum but not speaking english it is 
very complicated to find the right keywords to do a search.
dan asked me to modify certain parameters and despite all this does not 
work .... I do not understand what is happening.
here is the video link: https: //youtu.be/Ii0Q_5qiTsQ

when I start the machine the carriage comes in the top left and the X axis 
continues to force several seconds well when I type? in the console here 
is the message I get:
puis lorsque j'écarte la tête des fins de course voici le message que 
j'obtiens.
Uploaded files:
  • lightburn-gerbil-9.PNG
  • lightburn-gerbil-10.PNG
Hi,
I just found a start of a track. a friend told me that he had also 
encountered problems with this kind of card and a k40 with opto limit 
switch and that he had never managed to find a solution, he was forced to 
replace the limit switches with mechanical models.
so I disconnected the ribbon cable and connected the X axis motor with a 
cable directly on the mini gerbil card. then I connected cables to the 
connector (next to the ribbon cable connector on the gerbil card) to 
simulate limit switches, I wired them in NC. then I asked for a home 
return to the machine and I opened the limit switch contacts and the Y 
axis and the X axis stopped without problem just when I opened the limit 
switch circuit . it therefore seems that the card does not tolerate all 
opto limit switches.
is it possible to do something electronically by adding a component or 
must we replace the limit switches with mechanical models?
 

IDK if your problem is the same as what I had initially but sounds similar.  With my original M2 Nano board homing worked fine with K40Whisperer but when I installed the Mini Gerbil it would crash into the side when the X axis homed.   I have the Optical switches and what I ended up doing that resolved the problem was to loosen and adjust the switch position and the flag on the carriage and it fixed my problem.

I believe I've read some that suggest adding a resistor & capacitor filter to help with potential noise problem on the limit switches.  You might also look into adjusting $26 and $27 settings.   My settings are $26=250 and $27=2.500.  I think default the Mini Gerbil came $26=250 and $27=4.000

Thanks for your help ;-)
I already tried to change the position of the sensor without result. 
I will try again different positions and also see if by modifying the 
parameters it works. for the addition of capacitor on the contacts I 
think Paul has an opinion on the matter and I will wait to know what he 
thinks and especially how to connect them. in the worst case I would change 
the sensors for mechanical models.

Hi Vincent,

It is possible that electrical noise will distort the limit signals. However the MG has additional caps installed on the board to deal with that issue. However you can try to set the MG in USB power fed mode. Set Jp1 from 5vExt to USB5v. If that makes a difference that the 5V on the Laser power supply has a noisy signal. You can add some filtering caps to the 5v power rail at the laser power supply (normally a small coil and cap).

The disadvantage of setting jp1 on USB5v is that the MG will give an error when the K40 is not powered (24V DC is absent so the machine won't home and throw an error).

Cheers, Paul awesome.tech

In addition to this thread... I saw the screen shot where it says error 9. The limits are not triggered but the machine position says -480 so it seems it wants to go beyond 0.

Try to send some manual G-code commands like G0 X10 Y10 (G null)

Does it move in the correct direction? If the Gantry is inverted than it would move in the opposite direction of the Zero home position and run into the opposite corner of the K40.

Dan wrote a set up blog for the limits that you might want to check as well... Limit switches and homing

Cheers, Paul awesome.tech
good-morning Paul,
I tried to move the jumper so that the card is powered by USB but that does 
not solve the problem, the X axis will still bang in the chassis.
by typing the command "G0 X10 Y10" the carriage does not move and I have 
an error message as indicated on the attached image.


Uploaded files:
  • lightburn-gerbil-12.PNG

Okay, first unlock the controller via $X then issue the G0 X10 Y10 command and see if that get you moving.

Cheers, Paul awesome.tech
my grbl settings for position are "$ 3 = 1 $ 23 = 3".
when I switch on the machine the carriage goes towards the bottom on the 
left and bangs at the bottom on the edge of the left chassis.
then if I type the command $ X (+ enter) then I type the command "G0 X10 
Y10" (+ enter) the trolley crosses the whole table diagonally and will 
knock in the right corner towards me. I don't understand, it should move 
alone move 10mm towards X and Y.
even if i send the command G0 X01 Y01 it crosses the whole table and goes 
to knock in the lower right corner. And if then I ask for a return home it 
starts again at the bottom on the left and knocks in the chassis.


Uploaded files:
  • lightburn-gerbil-13.PNG
Hello,
that's it i think i have found the cause of all these problems. 
by looking again for the cause of my troubles i again dismantled the X axis 
sensor and observing with a magnifying glass i saw that the welds were bad. 
so I removed the solder and soldered again with a good quality tin, 
I reassembled the sensor and turning on the machine she did a funny 
maneuver ... she left at home then left from the opposite direction, 
I moved the sensor several times until I got proof that it was recognized 
in the lightburn console. then I restarted the machine is by miracle it 
works !! I do not know if it is the bad soldering or a bad position of 
the sensor but in any case it works well and I hope that it will last. 
strange that despite all it worked correctly with the nano card ??? 
thank you for the help you have given me, 
I hope to be able to enjoy my new card and my laser for a long time. 
Regards, Vincent.

12

Forum Registration

EDIT YOUR PROFILE HERE