Please or Register to create posts and topics.

bad mini gerbil

good morning, i connected mini gerbil to k40, homing direction ok, stop top left with lightburn, y and x direction are ok, came with vref y axis 0.33 and moves well, while x axis the vref came 0.31 and x-axis did not move, I had to raise vref x-axis to 0.80 in order not to lose steps, I have a problem: after 5/10 minutes the x and y axes no longer move, if I write in the console $$ the mini gerbil responds with all the correct parameters but y and x axes do not move, I tried to change the usb cable, I tried to keep the water and airassist off, I changed the 2 drivers with 2 new A4988s, I tried to use univesal gcode sender, to make the motors I have to disconnect usb and connect it again, but after 10 minutes the motors don't move anymore.
tell me some advice if it's faulty
I am attaching video and parameter files $$


Uploaded files:

Hi Marcello,


When you write about 'vref' I guess you're talking about the stepstick voltage.


If you think about the K40 mechanical system design, the Y axis motor must carry the Y axis and the X axis. Whereas the X axis motor only has the laser head to move. Given the X and Y stepper motors are comparable designs, there's no reason why the X motor current would have to be higher than the Y motor current. Our standard configuration is to have less motor current for X compared to Y. You've turned up the stepstick voltage way too much and now the stepsticks are going into thermal shutdown - that's why they don't operate after 5/10 mins. Fix any mechanical friction in they system and return stepstick settings to normal.


Key point #1 - Please check your X axis moves easily, the belt is not too tight and then return stepstick settings to normal, see https://awesome.tech/adjusting-stepsticks/


I looked at your wiring and noticed two white wires connected to your blue wires at the white plastic connector sitting on the bottom of the K40. What are the white wires? The K40 power supply has very limited energy to power peripherals. Whatever those white wires are, they are drawing too much power. After 5/10 mins, the K40 stepper motors are hotter, they present more resistance and then move less.


Key point #2 - Please try disconnecting those extra wires, change X axis vref back to normal and see the system operates normally.




punto 1 asse x si muove bene, la cinghia non è tesa

punto 2 i due fili bianchi sono 24v che accendono la luce, arrivati ​​così originali, non cambia nulla se li scollego

Ho abbassato la vref a 0.60 A, il mini gerbillo non va in protezione ei motori si muovono, ho provato a scrivere "ciao forum" 17mm/s  15%, perde passaggi e la scritta è un pasticcio, come possiamo rimediare?

Uploaded files:
  • IMG_20210227_124048.jpg
  • IMG_20210227_124104.jpg

hi forum, I had to change the x axis motor, I connected nema 17 from 1.7 A, I set vref x axis to 0.60, I do not lose steps and the mini gerbil does not go into protection.
now another problem has come, to cut the 3mm plywood I have to set lightburn to 6mm / s at 90% power, consuming an 18MA ammeter.
do you need to connect a second 24v power supply?

then I don't understand why after a few minutes lightburn freezes, while if I connect the universal gcode sender software the mini gerbil moves well


The 24V supply is just to drive the stepper motors, it doesn't affect laser strength. Cutting problems are likely because:

a) your optics (mirrors and lenses) are dirty or need replacement

b) you are out of focus

c) your tube is old

If you are having software related problems of freezing, you'll need to provide very detailed explanation of your process and settings.



with lightburn I solved, I did not home and it crashed.
the problem of the mini gerbil that delivers at most 10 ma ammeter, I did the test with UGS M3 S50 = 10 ma
M3 S500 = 10 ma.
they are not problems with mirrors, because with the m2 nano card it delivers 20 ma.
the problem started after i changed x axis motor, nema 17 from 1.7A, vref mimi gerbil x axis set to 0.60A

Forum Registration