EDIT YOUR PROFILE HERE

You need to log in to create posts and topics.

Test fire macro

Hi,

I found that the "G4 P1000" command paused forever with the laser on.

"G4 S1000" (actually S200 is long enough for an alignment flash on my machine) works on my setup.

I would have appended this to the original post, but it has been locked.

Richard

I had similar issue with using the macro as posted.   I found changing Dwell time  "P" value to 1 solved the problem for me.   It looks like Grbl follows LinuxCNC gcode standards and so "P" is seconds not milliseconds as some systems are.  Wouldn't it be nice if there were some consistency across platforms / versions to help avoid confusion. 🙂

I think the "S1000" your using is actually changing the Spindle Speed (PWM Pulse) rather than adding a delay time,  idk it's difficult finding accurate information across different variants of Grbl that may have changed version to version but you might look into it further. https://github.com/gnea/grbl/wiki/Grbl-v1.1-Commands

https://github.com/gnea/grbl/issues/343

http://linuxcnc.org/docs/html/gcode/g-code.html#gcode:g4

 

After further testing I'm finding the Dwell Time "P" doesn't really respond in seconds either.  I've went from 1 up to 400 with no change in the delay (about 1 sec) but when it gets to 450 seems to dwell indefinitely as it did when set at P1000  I'm beginning to think there's a configuration issue with Grbl or something idk but it definitely isn't accepting the G4 P commands as I'd expect.    Setting it to G4P1 does give about 1 sec fire so enough to do an alignment but it should still respond correctly to the given input imo.

Forum Registration

EDIT YOUR PROFILE HERE