EDIT YOUR PROFILE HERE

Buy your K40 accessories at https://SuperGerbil.com
You need to log in to create posts and topics.

T2laser testing

12

I downloaded the T2laser cutting/raster software to test it for a client. So far it has been impressive although I only managed to test the g-code sender component because of the trial version time out and g-code line limitation (1000 lines). It's useful if you just want to test or jog the machine as a starting point.

 

Uploaded files:
  • Capture2.JPG
  • Capture1.JPG
  • Capture3.JPG
Cheers, Paul awesome.tech

When T2laser generates gcode , it uses M03 to switch on the laser. You need to find/replace all the m03 code with M4. You could use notepad++ to do that. Happy lasering!

Cheers, Paul awesome.tech

Hi Paul, Is there a way to get the laser to fire with M03 because even the test switch will not work with T2 laser.

Also I am having a lot of problems figuring out how to home the machine.  It will home to whatever the position is when the laser is turned on.  Instead it should go to upper left until it see the limit switches (opto couplers).  Also the movement is not stopping when the opto couplers are over run.

This is more than just a T2 issue because it will not home in Inkscape and throws some errors.

Thanks,
Tim

ok, there may be a better way to enable test fire, but frankly I don't follow the installation instructions on this matter.  I think the 3 way switch is to use the middle leg of the POT and Test button during Test firing to connect the middle leg of the pot to the "In" signal of the PS, and then disconnect the middle leg of the pot during normal operation so that the "In" signal of the PS gets the PWM voltage from the controller.

As for the homing it seems I was able to set $ settings using CNCjs to have hard limits recognized and enable homing.  My controller had $22 (homing enable) set to 0
Studying github info on Gerbil now.  Do you have a complete set of settings for the run of the mill K40???

There is an error on this page...  https://awesome.tech/installing-the-gerbil/
it says reverse Y direction by setting $30=0, I think you mean $3=0.

I'm using FW 1.1e. Is 1.1f out now? Will it overwrite my $ settings?

Tim

Got it homing and otherwise behaving properly, but hit a snag....  My firmware seems to be incorrect as $28 is a float in my FW, not an integer.   According to this $28 should be an integer.

https://github.com/paulusjacobus/grbl

I will download the hex file from github upload to the controller and try again.

When you upload the firmware via e.g. extremeAVRburner, choose 328 because the 328pb is not listed but the burner does allow you to burn.

Fuse settings:

Low = FE, High= DE Extended=FF, no lock or calibration fuses selected.

BTW $28 is the pwm frequency (60Hz to 15kHz)) that you can choose. Just use 0 (zero) for the default 240 Hz.

Cheers, Paul awesome.tech

Thanks Paul, does uploading your FW also set all of the $ settings to default?

A new flash should not overwrite the $$ settings. However it's good practice to save your settings for future reference.

Cheers, Paul awesome.tech

After finally getting eXtreme Burner AVR to run, I still have  issues.  It looks like the libusb0.dll that's installed with eXtreme Burner does't work with Win7 64bit.  So I used another version of libusb0.dll and finally got it running.

http://extremeelectronics.co.in/avr-tutorials/gui-software-for-usbasp-based-usb-avr-programmers/

1) .hex file is being interpreted as corrupt from eXtreme Burner AVR (taken from Github, https://github.com/paulusjacobus/grbl  but looks to be about 1 year old)

2) USBasp drivers not installed.  Tried installing from zadig.

I'm confused how I got the wrong FW to begin with since I was expecting it to work out of the box.  I feel like I'm doing a lot of things I should not have to.  Is there a more straightforward way to program the FW?

Uploaded files:
  • NoUSBAsp.PNG
  • Version.PNG

Ok, this is a windows issue with the USB drivers for the USBasp flashburner since it is not a digitally signed driver. Some PCs do have that, others not.

Best is to select any of the usblibs from zadig2.exe which allows you to install the proper drivers. I tried many of these and most do work.

The hex file can be downloaded from the awesome.tech downloads menu https://awesome.tech/downloads/#

 

Cheers, Paul awesome.tech

Picture 1) Before zadig I had a Port-> USB Serial Port in Device manager

Picture 2) With zadig I installed FT231x UART USB drivers (libusb0).

Picure 3)After zadig I have a libusb win32-device-> FT231x USB UART .

Still same error in eXtremeBurner AVR (no USBasp).

The hex file in downloads shows up as html, but if I save as html, then rename to .hex it has a wrong file size and shows the same "corrupt hex" in the burner.

 

 

Uploaded files:
  • DeviceMgrBeforeZadig.PNG
  • zadig_dialog.png
  • DeviceMgrAfterZadig.PNG

Hi Paul,

The zipped hex file definitely works. Thanks for fixing the download link.

I definitely have the drivers installed properly, but eXtreme Burner AVR is definitely not working.  After installing on first run it gives usblib0.dll missing error.  After manually moving usblib0.dll to windows\system32 and syswow64 I can get eXtreme Burner AVR to run but still same error missing UBSasp error when trying to do a read.

Can you come up with a command line or config file for avrdude?  XLoader seems to connect because the board will reset, but gets stuck on uploading and never progresses and no feedback.  I'm surprised I'm the first one with this issue as I have not modified the FW from what you shipped to me, but it has sat near the K40 for a while for me to get around to installing it.

Here is what my drivers look like with a clean install on Win7 64 bit  usig the FTDI drivers (CDM v2.12.28 WHQL Certified.zip) .

Help would be appreciated.

Thanks!

Uploaded files:
  • CleanFTDI-Install.PNG

ok, I had an epiphany on the way to work as my brain was working in the background trying to reconcile everything I'm seeing and I think I understand what's happening.

Still cannot program the new FW, but I now understand the FW I have and T2 Laser settings.  I will verify when I get home and post an update later.

Tim

ok, my epiphany is this...

In grbl there is a $30 max power parameter (or max spindle  parameter).  The default is 256, so if you set this to 128 you'd think limiting the max power to half by giving it a max PWM of 50% of the default.... INCORRECT.

It's a misnomer and instead should be called max power increments.  If you set this to 2046 (as Paul has done), then when you send a command with Sxxx such as S256 you're using a PWM % of 256/2046=12.5%.  In order to have the parameter be used to limit the max power for example to 80% you need to set T2 max power to 1000, then set the max power increments to 1250 -> 1000/1250=80%.

Still unable to update my firmware and it's alarming constantly and the inability to do so on multiple computers definitely seems to be a hardware issue.

I have use various USBasps and they all work fine with various drivers like libusb etc. Would you like me to send one to you so you can test that one that works for sure? Just pm me,

Apologies for the late reply, I'm preparing another kickstarter and the people behind KS don't have a phone number, so it hard to solve issues.

cheers, Paul

Cheers, Paul awesome.tech
12
Buy your K40 accessories at https://SuperGerbil.com

Forum Registration

EDIT YOUR PROFILE HERE