EDIT YOUR PROFILE HERE

You need to log in to create posts and topics.

Steppers Grinding/Stalling after job completion.

I can not find the reason yet but everyday at some point this problem starts where the steppers stall and start grinding and the head doesn't go back to the Origin.

Most time I have to kill the machine and hit stop in LB to clear it. Sometimes I can power cycle the machine and hit home then origin and it's fine.

Take a look at this video.
https://photos.app.goo.gl/dkVjTS7V9hdNyKw88

Thanks,
Eric

 

Settings Below

$0=10

$1=255

$2=0

$3=1

$4=0

$5=1

$6=0

$7=0

(ATC M6, pulse/ff)

$8=100

(ATC Tool Td, milliseconds)

$9=100

(ATC M6 Td, milliseconds)

$10=31

$11=0.010

$12=0.002

$13=0

$19=0

(Softstart, milliseconds)

$20=0

$21=0

$22=1

$23=3

$24=2000.000

$25=2000.000

$26=250

$27=2.500

$28=11

(Spindle freq. 0 to 15)

$30=1500

$31=1

$32=1

$100=158.395

(x:stp/mm)

$101=157.583

(y:stp/mm)

$102=160.000

(z:stp/mm)

$103=160.000

(a:stp/mm)

$104=160.000

(b:stp/mm)

$110=13500.000

(x:mm/min)

$111=5000.000

(y:mm/min)

$112=5000.000

(z:mm/min)

$113=5000.000

(a:mm/min)

$114=5000.000

(b:mm/min)

$120=8000.000

(x:mm/s^2)

$121=3000.000

(y:mm/s^2)

$122=3000.000

(z:mm/s^2)

$123=3000.000

(a:mm/s^2)

$124=3000.000

(b:mm/s^2)

$130=230.000

(x:mm max)

$131=320.000

(y:mm max)

$132=200.000

(z:mm max)

$133=200.000

(a:mm max)

$134=200.000

(b:mm max)

Hi Eric,

Thanks for posting video, that makes it easier for us to help you.

As per my other response to your other post, please ensure you’re using v 0.9.02 or later of Lightburn.

On the mechanics side:

1              I can see the issue is affecting the X movement.  I suspect that your K40’s x belt is a little bit tight.  If you loosen that off, your problem may be solved.  See:

https://www.reddit.com/r/lasercutting/comments/3vqtfw/k40_overtight_yaxis_belt_leads_to_grinding_noise/

Please try that out as an easy first step.

2              I can see from your video that you’ve got an air-hose arrangement fitted.  Nothing wrong with that.  But keep in mind that your stepper motors need to move the mirror, lens, and now the air hose tube and any tension in that air-hose.  To see whether the air-hose is contributing to stalling, you could temporarily remove it from the gantry, and see if you still experience stalling at high speed.

On the control system side:

3              The Mini Gerbil uses A4988 stepsticks, which are dedicated circuits for controlling the stepper motors.  The stepsticks contain a tiny trimpot adjustments that allow more current to flow through the stepper.  The stepstick on the edge of the MiniGerbil (next to the X axis label) is the one to adjust with a very small screwdriver.  Turning the trimpot slightly clockwise (eg. 1/8th of a turn) will increase the current available to the motor, providing greater acceleration.  Note that the K40’s PSU only has a limited amount of current it can supply, so don’t simply turn the trimpot to maximum, as that would steal too much current from the Y motor to give to the X motor.  Changing the trimpots should only be done when you’re confident that there aren’t mechanical issues at play.

All the best,

Dan

Thanks for the reply Dan.

My steppers had been performing well at 320-350mm/s with the older controller since the upgrade I am at 222mm/s.

The randomness of the steppers stalling going back to origin makes me think I have a setting at the edge of  my steppers max acceleration. I was hoping the settings I shared might shine some light on something that doesn't look right.

I just purchased the MG and LB, I have the most up-to-date version of LB. 0.9.02.

The air assist is center in the machine so the Carriage is not tugging on it in the same manner as when they are placed in the back right corner.
(Working on finishing up my cable chain install)

The A4988 drivers are identical to my 3D printer I built. I tuned them to up to 500ma and the steppers got hot and got worse. So that was a kill joy quickly.

Best,
Eric

Hi Eric,

I've looked at your $ settings and note they’re pretty much the default values that work well with other K40’s.  Here's my nerdy analysis: 

max x speed $110=13500 mm/min=225 mm/sec.

x acceleration $120=8000 mm/sec/sec.

Using v^2 = u^2 +  2aS, this means that we're asking your gantry to accelerate to top speed in 3.16mm, which intuitively seems like a best-case scenario.  If we try reducing the acceleration setting, your gantry's top speed won't change, it will just take, say 6mm instead of 3mm to reach that top speed.

So for testing purposes, please set $120=4000 and see what happens.  You may find that it now doesn’t stall and can reach top speed.  You may be happy to leave it at that, and in fact then even try increasing top x speed $110 as desired.

If you want to pursue higher performance beyond that, you must look at your mechanics.  My interpretation of Newton’s law F=ma in a K40 context, is that the most likely reasons for stalling are:

* Belt tension – this effectively produces a counter force, which reduces net Force available to accelerate mass.  Please go ahead and review the tension in the X belt.  I appreciate that the tension may have been right for the previous controller, but each control system has different dynamics, and when we're aiming for high performance, the belt tension can make a big difference.  Besides, belt tension can change over time, or possibly as a result of any crashes during setup or testing.

* Additional mass.  For a given amount of stepper motor force, acceleration is inversely proportional to the mass.  I appreciate your other comment that the air-hose is balanced with respect to left-right tension, that's great.  But it's not the same as zero tension.  Maybe it's not a problem, I can't judge the tension remotely, but to be thorough let's try it.  Also, I can't tell from the video how much your customisations weigh - extra weight reduces acceleration.  Please try disconnecting all brackets/fittings/hoses from the K40 gantry, just strip it back to the from-factory condition, and re-test.  Then we can rule out that as a potential issue!

Yes, overdoing the current adjustment on the trimpots can be problematic, but a small increase may help.

So I spent the whole day since about 9am working on the gantry etc.
I put a whole new gantry, belt, carriage, wheels etc etc in, its smooth as ice now.
Tuned the steppers up to 460ma so far.

I can not get it past 13643mm/m. It's the craziest thing but the second I go from 1343 to 1344 the X stepper stalls. I have dropped the Accel down to 1000 it doesn't care.
But doing like a thin line or number 1 in LB I can do $120=8000 mm/sec or $120=12000 mm/sec and it fly's, etching the line unbelievable fast without issue and etching looks mint.
It does very well other wise but I can not get more than 227.4mm/s exactly out of it without X stalling.

Dumping all the baggage (hoses and wiring) I did first before I ever made the post and did it again but didn't make a difference.  The carriage wheels had some minor flat spots in them and they had to be adjusted just ever slightly tight to get rid of slop. The brand new carriage is as smooth as one could ever be.

Eric

Hi Eric, that's strange and I would suggest to swap out some step sticks and see if that helps. Also try a separate G-code sender e.g. CNCjs and see if the issue persist or goes away so we can pinpoint the bottleneck.

Cheers, Paul

Cheers, Paul awesome.tech

Forum Registration

EDIT YOUR PROFILE HERE