EDIT YOUR PROFILE HERE

Please or Register to create posts and topics.

Settings Within Lightbrun

So I had this all working somehow last year but had to move to a new computer and reinstall lightburn and dont have access to the old machine to see what I did.

I think I have the v.1 grbl board and everything seems to be working because if I reconnect the Variable Power pot, the test button will fire the laser and the power is adjustable via the POT.  But I cannot for the life of me get LightBurn to function properly.

Can someone confirm the settings I should be focusing on. From what I can tell, I should be using the GRBL driver and not the GRBL -M3. Which if I do I can get the laster to run and fire but even with the cut power set to 100% it only puts out 10 mA on the analog output display on the laser and it stays on during travel. The power doesn't change based on changing that setting movements (I read this is because I need to set $32=1, not $32=0) not sure how to do that yet.

Here is a gallery of images associated with what I am working with including a picture of the $$ response (sorry about the picture of text but I was in a rush).

I am fairly confident that the wiring is correct because it was working a year ago but then I read that the other two wires from Pot (Grn/Blue in the pic) should be removed and I hadn't done that they are still connected to the POT only the I has been cut and hooked to the GRBL board. Then I saw the installation video that does not disconnect those but its a slightly different power supply.

In both the plain GRBL driver, the GRBL STM, and GRBL -M3 versions the movement controls all work correctly and fun stuff like that. It is really just getting it to fire and adjust power that seems to be messing me up.

I really appreciate any insights with this. I want to get this all figured out before I try to upgrade my other K40 in the classroom. 🙂

 

Ok. So GRBL is setup correctly and the laser is firing correctly. Variable power is working but it is still capping power at 10 mA on the dial at 100% cut power in LightBurn.

If I reconnect the POT I can get the power to adjust via the pot higher then 10 mA but then the laser does not switch on and off. Hmmmm

Hi Hegemone.

the power settings on K40's are an interesting area as they come back to what the user is actually trying to achieve.

In general we don't encourage/recommend use of the POT once you have the Mini Gerbil in place. Apart from the extra wiring, the mixed use of analog and digital controls doesn't do much for repeatability. For example, once people find a cutting or engraving power setting they're happy with on their PC interface (eg. Lightburn), then if there's a POT that adjusts it, they'd need to have a marker on their POT dial (and remember to adjust to it) so as to get the same effect as last time. It's a lot cleaner just to adjust power at one point in the PC interface.

Having said that, let me know if you're absolutely keen to wire in the POT (I'm curious about the reasons why). For starters, I'd like to review how you've already wired it (please provide diagram). Then, I should be able to come up with a wiring diagram that uses the POT to control the output of the PWM.  So essentially the POT would scale (0-100%) whatever PWM output you're using. With such a system in place, you would set the PC interface to a high level, and then use the POT to scale it down as desired. Let me know if this is the effect you're after.

Cheers
Dan

Thanks for the response. It's not that I want to use the POT, I just used it to test that he laser was able to run over 9 mA. The grbl + lightburn is capping the output at about 9 mA when I set the cut  100% in lightburn. If I disconnect the digital power signal the laser and reconnect it the pot then the laser will operate at the higher levels. I know you shouldn't run it at max power but it should run just fine at  about 18mA which I am not getting with the grbl digital signal.

Is there setting in an run in lightburn to turn up the max power?

 

Hi Hegemone,

as far as I know, setting Lightburn's 'Power Max' setting (see the Cuts menu on right hand side of screen) to 100% should give you just that: 100%.  I'm not sure what work you're doing, but don't think you'd actually need 100%.  For example, on my K40 (with new tube), my Lightburn power settings range from 8% to 40% for marking paper through to cutting 4.5mm acrylic.

It seems like there's some other issue... how do you know Mini Gerbil +lightburn is capping the output 'at about 9mA'? If you're reading that from on the meter then it's likely that the meter and/or pot is actually loading down the PWM signal and reducing laser power. So, please ensure that the Mini Gerbil's PWM output is going straight into the power supply as shown in Mini Gerbil instructions with no other wiring involved in the PWM signal.

Cheers
Dan

Thanks for the response. I guess I should try removing the grbl an other wire from the pot connection to verify there is no issue with that though it's connected just like the video for the v1 grbl board you posted. The red wire just goes straight to the board.

When I was running the laser to cut 5mm plywood I found the sweet spot for speed and cleanliness to be about 12-15 mA when I was using the laserweb Chinese software and manual controls so that's why I wanted to go above 9 mA. At 9mA even cutting cardstock clean through is down to 600 mm/ sec when it could be much quicker.

I guess it's time to check a different software to see it that might be it.

 

Hi Hegemone,

I couldn't exactly understand your sentence "...removing the grbl an other wire from the pot..." but if you're ensuring the PWM wiring just goes straight form Mini Gerbil to Laser Power Supply (without any other wires from the K40 front panel joining in along the way or at the same power supply terminal) then you're doing the right thing.

In general, there will be differences between controllers and software so it's probably more confusing that it's worth to think about what your power settings used to be.  Since installing my Mini Gerbil I've simply kept a fresh notebook about what speeds and laser power % settings in lightburn work for my materials.  Of course, if you can't achieve the same engraving or cutting as you did before let us know and we'll keep debugging.

Cheers

Dan

To confirm the red "I" wire" from the power supply goes directly to the pwr post on the grbl, no splices. The pot also has 2 more wires connected to the power supply a ground and another (small green and blues in the pic of the power supply) that are still connected to the power supply.

Pictures in the gallery here

I was getting one or two pass cuts through 5mm ply at right near 1000 mm/s before the move and new computer. I can't even imagine how many passes and slow speed wold be required now.

I would almost prefer manual control over variable if variable is so low power  but I am not sure how to achieve that because if I just rewire the pot back to stock and detach the pwr wire from the grbl, the laser stays in during traverse movement and when it's done and returns home which is not good.

At some point I guess I should just try the newer version of the board if it works with the non ribbon cable version of the k40.

I'm not really familiar with the board you have but assuming you have it all wired correctly a few settings are worth looking into.

$28 on Mini Gerbil is for setting the PWM frequency default of $28=5.  I'm not sure what $28 represents on your version but you show it set at 0,  You might look into that setting.

Spindle Speed ( Laser Power) $30=1000 on Mini Gerbil.  I see your set to 2048 you might try adjusting that setting while making sure Lightburn S-Value max matches that setting.

Laser Mode $32=1 on Mini Gerbil,  But I'm not sure if your firmware supports it or not you'll need to look into it.

I will definitely look at those. I should have posed the device settings screen from lightburn as well  Thank you so much for taking a moment to share your insights.

So that appears to be it. With $28=5, $30=1000 it works just like it used to. 100% cut in LightBurn pins the mA at about 25.0 meaning I can now adjust the full range of the machine.

I do understand that running the machine sustained at over 20 mA is strongly discouraged. and I should use the minimum required to get the desired effect.

Thanks to you both for helping me run through the potential issues and finding a solution.

Great!

You're welcome.

Dan

Forum Registration

EDIT YOUR PROFILE HERE