Please or Register to create posts and topics.

Set defaults to mm/sec ?

Lightburn with gerbil STM seems unable to run in mm/sec mode, rather than mm/min? All my files and profiles on Ruida machine use mm/sec and it's a pain converting. Setting mm/sec in Lightburn under "better for CO2 seems to do nothing to axis speeds?  Issuing F10 should make axis travel at 10mm/sec - it doesn't - a command of G1X100F10 took 1 minute 54 seconds rather than 10 seconds? What am I missing?

All the controller $ settings are in mm/min. There is no need to change or translate them. When switching over to mm/sec in lightburn,  there is also no need to translate since G code just works in mm/sec. We use the mm/sec setting in lightburn by default. The setting that causes the slow move is in the home/move tab.

Cheers, Paul awesome.tech

Right - just created a quick test and Lightburn shows speed as 400mm/sec but actually outputs F in mm/min in gcode - explains it.. Thanks.   Out of interest- why were mm/min used in controller as default units?

; LightBurn 0.9.24
; Gerbil-STM device profile, absolute coords
; Bounds: X71 Y50.05 to X170 Y119.95
G00 G17 G40 G21 G54
; Scan @ 400 mm/sec, 80% power
; Layer C00

The original base code is Grbl which was created for CNC controllers. We ported it to a STM32 processor and rewrote lots of the code. The defaults can be easily rewritten in mm/sec but then laser software like Lightburn needs to change as well.  I guess that's a bridge too far.

Cheers, Paul awesome.tech

Yea - noticed the Linux version of gcode rather than the Nist RS274 version too after delving  🙄  Had many a year arguing with them re G32 NOT linux G33 🤣


Paul has reacted to this post.

Forum Registration