EDIT YOUR PROFILE HERE

Forum breadcrumbs - You are here:ForumMini Gerbil: Installation issuesRotary
Please or Register to create posts and topics.

Rotary

Hello Paul,

I tried to connect my rotary on the y axis. When I turn on the k40 the message appears:

Homing

ok

ALARM: 9

ok

Grbl 1.1f ['$' for help]

[MSG: '$ H' | '$ X' to unlock

 

I activated the rotary function  also in lightburn software but I still get the same error.

can you help me?

 

Thank you

Alberto

Hi Alberto,

A rotary does not have a limit switch so the machine cannot home. Just disable the home option in the driving application. e.g. Lightburn click on device, select STM-Gerbil, edit, disable home on startup option.

Without the homing you need to set your origin manually in your driving application or in Lightburn via the Move menu (move to position and click set origin).

Assuming you use lightburn, On start up, drag the 'google pointer' to the spot where you have the rotary, read out the position (get position button), click 'set origin' and start the test engraving there. Adjust a bit till right and do the final engraving.

Good luck!

Uploaded files:
  • LightBurnHomeOption.PNG
  • SetOriginLB.PNG
Cheers, Paul awesome.tech
  1. Hi Paul followed your instructions and have had some joy with my rotary, however once I stop the process of engraving I received the same error 9 and have to switch off the k40 before I can burn again is there a remedy?

I believe you need to turn off homing (with a rotary you cannot home). In Lightburn you can turn off the homing on start up. Click on Devices button, edit the Gerbil-STM gcode driver. Uncheck the home on power up check box.

Cheers, Paul awesome.tech

Cheers Paul had disabled auto homing but wasn't using the smt version will install that and give it a go thanks!

Forum Registration

EDIT YOUR PROFILE HERE