Please or Register to create posts and topics.

PWM Intermitent response:

Hi again gang.

I am sssoooo close to getting this sorted.
I have had real success over all and just a couple of "hickups" to work out.

1) Engraving is working but only at $28=0  and not at =5 (1Khz). It is a bit "dotty" but hey, not bad. At 1Khz there doesn't seem to be any PWM response so the power stays at max even at slower speeds.

2) The really glitch I am working on is that the power is not responding consistently.
I can be ticking along fine and all of a sudden it just stops responding.
All the "mechanical" commands are fine. Homing, tracking while engraving etc.
Only the Power (PWM?) stops changing and it pretty much stays on at near full power.

Grounding has been checked and is fine.
I have tried both EXT and USB power via jumper change and not difference.
It is an older laptop running WIN 8. Could that be a problem?

Do I need a shielded USB cable?

Here are a couple of pics showing successful engraving then where the power stays on.

I know they are trashy pics and ignore the square but it gets the point across as to what is happening.
You can see how it starts engraving the "house" from the bottom then just stays on and draws lines.

Again, thx in advance for your help and for a great product.

Uploaded files:
  • House-1.jpg
  • House-2.jpg

Hi Robert, glad that you're getting there slowly. What concerns me is that the laser only works on 60Hz PWM, it should do 1kHz without any issues. 60 Hz gives you those dots which seems very low res for the need of engraving. I wonder if this is a PSU or Tube issue. How old is the Tube? Maybe it does need a high threshold to ignite hence only working at 60Hz...

I would try a shielded USB cable and a different laptop (WIN10 recognises the driver automatically) to see if there is a difference so we can narrow possible culprits down.

I don't think you have a scope but maybe you can borrow one and check the PWM signal. Does it get distorted or not? If so that might indicate a issue with the PSU.

Okay keep us posted on your journey!

Cheers, Paul awesome.tech

Thanks Paul.

A new USB cable is on its way.

It is a fairly new K40 unit so I think the tube is fine.

The main problem using 1Khz is there seems to be no attenuation of laser power when engraving.  It just blasts away at a high level.

I will do some more testing with power levels if you think it should work fine.

I'll also do some testing with my stronger Win 10 computer.


Hi Robert, yes it is still very strange and not something I have come across yet. Ideally we should use a oscilloscope to test the PWM levels and frequency. If I had to speculate then I would say the PWM IN opto coupler on the PSU might be the culprit. However this requires some more measurement. You could add an additional resistor of 1KOhm in series with the PWM wire to see if that has any impact (no full blast at 1kHz or no lasering at all or just working now?).  I know it's a bit far fetched but experiments like this can hint in a direction to investigate or not.

Cheers, Paul awesome.tech

Is this not a thing of beauty?!!!

I was so excited I came running in from the "workshop" to show you this (I really need to get out more).

I ran it on a better Win 10 laptop. Had to drop the power from 20% to 3% ($30=1,000, LB max is 1,000, $28=5).

Except for a few hangs when making adjustments it went smoothly.

Maybe the new USB cable will help that.

Thanks again for all your help Paul

I will insert the resistor in the PWM line and try that next.

Uploaded files:
  • House-2.jpg

Forum Registration