EDIT YOUR PROFILE HERE

You need to log in to create posts and topics.

noise on serial connecttion

I just installed a minigrbl in a K40 laser. Everything seems to work at first, homing, move, test fire, etc., but there is a lot of strange traffic on the serial line tat I am not seeing in other grbl setups that I have. I get "check door" messages, lots of error:2, error:8 messages and unrequested status/position returns. It is very unpredictable and unusable...

I have tried two separate computers with the same behavior that I use consistently with other systems. I have validated grounding on the device and it worked with the original crap controller.

ok
[VER:1.1f.20190214:]
[OEM:Awesome.tech . MiniGerbil:]
[SER:0x000007.Date:20190214:]
[OPT:VMZL,15,254]
ok

ok
$0=10 (Step pulse time, microseconds)
$1=255 (Step idle delay, milliseconds)
$2=0 (Step pulse invert, mask)
$3=1 (Step direction invert, mask)
$4=0 (Invert step enable pin, boolean)
$5=1 (Invert limit pins, boolean)
$6=0 (Invert probe pin, boolean)
$7=0 (ATC M6, pulse/ff)
$8=100 (ATC Tool Td, milliseconds)
$9=100 (ATC M6 Td, milliseconds)
$10=31 (Status report options, mask)
$11=0.010 (Junction deviation, millimeters)
$12=0.002 (Arc tolerance, millimeters)
$13=0 (Report in inches, boolean)
$19=0 (Softstart, milliseconds)
$20=0 (Soft limits enable, boolean)
$21=0 (Hard limits enable, boolean)
$22=1 (Homing cycle enable, boolean)
$23=3 (Homing direction invert, mask)
$24=2000.000 (Homing locate feed rate, mm/min)
$25=2000.000 (Homing search seek rate, mm/min)
$26=250 (Homing switch debounce delay, milliseconds)
$27=4.000 (Homing switch pull-off distance, millimeters)
$28=5 (Spindle freq. 0 to 15)
$30=1000 (Maximum spindle speed, RPM)
$31=1 (Minimum spindle speed, RPM)
$32=1 (Laser-mode enable, boolean)
$100=157.000 (X-axis travel resolution, step/mm) (x:stp/mm)
$101=157.000 (Y-axis travel resolution, step/mm) (y:stp/mm)
$102=160.000 (Z-axis travel resolution, step/mm) (z:stp/mm)
$103=160.000 (a:stp/mm)
$104=160.000 (b:stp/mm)
$110=12000.000 (X-axis maximum rate, mm/min) (x:mm/min)
$111=5000.000 (Y-axis maximum rate, mm/min) (y:mm/min)
$112=5000.000 (Z-axis maximum rate, mm/min) (z:mm/min)
$113=5000.000 (a:mm/min)
$114=5000.000 (b:mm/min)
$120=8000.000 (X-axis acceleration, mm/sec^2) (x:mm/s^2)
$121=3000.000 (Y-axis acceleration, mm/sec^2) (y:mm/s^2)
$122=3000.000 (Z-axis acceleration, mm/sec^2) (z:mm/s^2)
$123=3000.000 (a:mm/s^2)
$124=3000.000 (b:mm/s^2)
$130=320.000 (X-axis maximum travel, millimeters) (x:mm max)
$131=230.000 (Y-axis maximum travel, millimeters)
(y:mm max)
$132=200.000 (Z-axis maximum travel, millimeters) (z:mm max)
$133=200.000 (a:mm max)
$134=200.000 (b:mm max)
ok

Any suggestions?

Billy

I will add that I had to edit the output above because it had extra line feeds in it in a lot of places. Those line feeds are not present with another grbl controller that I use for a CNC.

Hi Billy,

A bad earth (green/yellow) on the K40 and or middle prong of the mains outlet or plug or a bad defect in the laser power supply, causes the return path of the laser power to go through the USB gnd shield. This is bad and potentially dangerous. See K40 laser grounding instructions

You can test this via an ohm meter (multi meter) and measure the resistance between the middle prong and the K40 chassis. Run a laser job without the Fire laser witch pressed and if the job runs fine then it's sure an earth issue.

Alternatively you can set JP1 from 5Vext to 5vUSB so the board is powered via the PC. It's not a cure but it gives you a debug test as well.

Hope this helps, Paul

Cheers, Paul awesome.tech

Thank you Paul... I checked the ground between the plug and the chassis earlier, but will check again.

So it turns out that the ground between the plug and the chassis was good. I had corrected that before the minigrbl install because it zapped me.  But there was no ground between the laser power supply and the chassis. A nice fat jumper between the ground lug and one of the screws in the power supply did the trick.  Thanks for the help.

That's great to hear Billy. I hope it is now working properly.

Cheers, Paul awesome.tech

Forum Registration

EDIT YOUR PROFILE HERE