Please or Register to create posts and topics.

New Gerbil install, no laser activation

Hello all,

Just installed the controller and got the limit switches and X/Y travel worked out, but I'm still not able to activate the laser through the pwm output on the controller. I verified the laser still works by jumpering the 'IN' connection (where the PWM output from the controller goes) to the +5v pin and using the test button on the panel.

I'm wondering if I should be able to read the output of the PWM pin with my RMS multimeter to verify the pin on the controller is working, or if there's a better test for it.

I'm using CNCjs to access the controller console for testing.




Hi Shawn,

I had the same issue.

Try pressing the test button without engraving. If it does not work - that´s a good sign.

Next run some engraving/cutting g-code and press the test while the job runs. If the laser fires you just have to short the test button.

That worked for me.



Wojswoodshop has reacted to this post.

The Laser PSU has two logic gates that need to be grounded in order for the laser to be fired by the controller over the LO and IN connections.

They are labeled WPS (water protect switch) and LPS (loop protect switch). They are the most three left connection screw terminals of the middle terminal block (which has six terminals in total). WPS, LPS and GND can be tied together on the terminal. LPS normally goes also to the Fire switch on the K40 panel but in some cases it has been wired differently depending on the manufacturer or sub contractor (k40s are produced by many Chinese factories).

Cheers, P

Cheers, Paul awesome.tech

I have the same issue but not the PSU as described. Is shorting the test button the next step? My machine works fine IF I hold the test button while running a test file, nothing otherwise.



Forum Registration