Please or Register to create posts and topics.

Mini Gerbil Installed, Moved once and Never Moved Again

I have send a support email out but now I'm registered on here hopefully someone can help me.

I installed the Mini Gerbil in my K40 replacing my m2 nano yesterday. The actual installation was easy, I have a type 2 PSU so installed the cable to that fine, and only issue was I found the limit switch plug (non ribbon) was reversed so that went in turned around to make sure x and y were mapped right.

The first time I turned it on all seemed fine, plugged it into my pc, found it right away, lightburn auto detected it and configured it fine. The first thing I did was hit the home button and it moved in both x and y towards the home switches but it bounced on the y switch and stopped never reaching the X. This was wrong so I turned off the machine to read over the forum and install info again.

After some research, I found a few possible fixes on the forum so I turned it back on and it tried to home automatically but the motors didn't move and the console pops up with :-

Waiting for connection...

Grbl 1.1f ['$' for help]



[OEM:Awesome.tech . MiniGerbil:]



Target buffer size found




Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.


Grbl 1.1f ['$' for help]

[MSG:'$H'|'$X' to unlock

I haven't had the machine move with the mini gerbil since and I hadn't touched the hardware since turning it off after the bad homing. Since then I have:

  • Disconnected the board and plugged the m2nano back in and it moves and homes just fine
  • Checked the plugs are seated and correct onto the board
  • Typed $X and tried moving the laser using the arrow buttons on the move screen, it didn't move but from the console info it seems to think it is moving.
  • Replaced the mini USB cable in case there was a data issue, same result
  • Tried a different PC from another machine and got the same lack of result
  • Tried using Laserweb, again with the same output as above (Alarm 9)
  • Switched over to USB powered briefly and got the same result (suggested on the forum)
  • Turned off Auto homing in the device setup to see if it would move if it wasn't asked to home when booting, Still no movement

Basically, as far as I can tell the board isn't sending move commands out to the motors, which seems strange given the first time I turned it on it did move.

I'm attaching pictures in the hope they may help. Thank you in advance for your assistance!

Uploaded files:
  • PXL_20210825_214851394.MP-Large.jpg
  • PXL_20210825_214904903-Large.jpg
  • PXL_20210825_214914937.MP-Large.jpg


I bought some new stepsticks because that's the only thing the troubleshooting says and no reply yet.

I set them to the setting shown on the stepstick adjustment section and put them in the machine and the X axis now begins buzzing when I try to home the machine. Y still doesn't seem to be doing anything.

I tried adjusting them up for more power but I don't know what I'm doing so I've stopped at about 90 degrees up from their base setting and still only buzzing, no movement, how far should I be turning these? I'd really appreciate some help here.


I have finally managed to get it moving!

I installed the new stepsticks again, rather than putting them to the default shown in one of the blogs I decided to start lower and work my way up and to my surprise when I turned it on, the Y moved. Turned it back off and adjusted the x counterclockwise to be even lower and tried again and they both moved and homed. I'f I'm correct from the information I have here I reduced the pot when I turned them counterclockwise, I don't know enough about them or the motors to know why it worked but it did.

They were a little herky jerky so I spend a little time adjusting the pots a fraction at a time and now I have the machine moving and cutting. There is a still a little very slight jerkyness you can see if doing a fine engrave but I'm going to clean my rails before I blame that on the board with it being so tiny.

I do seem to have a problem with the signal getting interrupted when doing a longer engrave so I will have to look at whats causing that but with now I can at least do the basic work. If any can help on the interruption issue or link me to solution id be thankful but its not a grounding issue, or USB length issue and the USB is away from the PSU and power cables so its non of those.

If you are using a laptop computer, chances are your interruption (lacking further description) could be caused by the USB ports being set to power down/sleep.  Google how to prevent this.  All laptops seem to be set this way by default to save battery power.

Forum Registration