EDIT YOUR PROFILE HERE

You need to log in to create posts and topics.

Legacy Gerbil + Lightburn - Blue Laser Enable Stays on

Hi,

Not sure if this a software or hardware thing - The blue led to indicate laser (and laser enable itself) stays on after I complete a job in Lightburn. - I can see from the voltage probe that the rightmost pin on the power supply is being pulling the pin down to gnd.

Resetting the gerbil puts it back to high so I am assuming it's something on the board?
I am almost certain the wiring is all OK, all connections have good continuity as far as I can tell.
I've tried moving wires around but it stays the same. I used a dpdt switch to control where it signal is from the PWM or the test pot ( I use this for test firing etc.) - Of course as this pin is being pulled to ground switching to use the test signal fires the laser (as it is the same effect as pressing the test switch).

It's not a massive hassle to reset the board via LB after each cut but seems like it shouldn't be necessary.

I can't see anything obvious in the Light burn settings but probably something I have missed.(I am using the latest 9.07 version of Lightburn)

Cheers

Bob

Hi Bob,

You can test the controller's functioning via the M commands via LightBurn's command console.

The LO port is controlled by the G-code commands M3,M4 for laser on and M5 for laser off.

M4 is being used in laser mode ($32=1) and only turns the laser on will the head is moving. This is a safety feature to prevent fires. M3 turns the LO port on without motion but the controller needs to be set in cnc mode $32=0.

Easiest to test is just entering a M5 after the streaming is finished and see if it turns off. If not then it's a board issue and we will replace it. If it turns off then it's a missing statement in the G-code. Make sure that the correct device driver is chosen Gerbil-STM

Cheers, Paul awesome.tech

"Make sure that the correct device driver is chosen Gerbil-STM" -

Hi, many thanks for your super fast reply,

This is the legacy gerbil so I assumed it needed to be GBRL driver (I tried Gerbil-STM but it doesn't even connect). Is that correct? There is a GBRL-LPC and GBLR-M3 but GBRL seems to work other than this issue, wasn't sure what the difference way the others seemed to target older version of GBLR )
M5 doesn't appear to do a great deal - it return OK but laser stays enabled. However calling M3 after a stream does disable the Laser (LO goes high) - (The trick works regardless of the setting $32 is on)
Do these commands differ between the Gerbil versions? I wonder if I need to flip something in Lightburn.

To confirm after a stream has finished sending an M3 command does disable the laser so I am leaning towards a software or streaming issue. (I have experienced the odd occasion where LB / Gerbil pauses mid job and doesn't continue which I guess was similar communication issue (although no errors are reported in either it just hangs for ages until I give up and stop / reset) my process of rebooting the board before each job seems to reduce that somehow.
I am using Linux (Ubuntu 18.04) in case that makes a difference.

Below are my $$'s in case there is anything obvious in there:

$$

$0=10

$1=255

$2=0

$3=2

$4=0

$5=1

$6=0

$10=31

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=1

$23=3

$24=600.000

$25=1000.000

$26=250

$27=5.000

$28=0.000

$30=1000

$31=0

$32=0

$100=157.000

$101=157.000

$102=250.000

$110=3000.000

$111=3000.000

$112=500.000

$120=3000.000

$121=3000.000

$122=0.000

$130=320.000

$131=230.000

$132=-0.000

ok

Thanks again

Seeing this issue quite regularly now - The laser starts an engraving run and stops mid way - No messages on the board or in Lightburn.
To rule out the software I exported the gcode files and ran the same project from CNCJS - this had the same result - random lockup (doesn't stop in the same place each time)
Only solution seems to be reset the device then it comes back to life. It seems to happen more on a couple of specific jobs not sure what is special about those.
(This is one of the kickstarter avr sandwich boards)
Are there any jumper settings I can adjust to try?
I have rechecked the wiring and grounding all seems ok. Tried with and without and external 24V supply - no difference that I can tell.
Only thing I can possibly thing of is that I have a switch for the Test signal  wired up (to switch between PWM gerbil output and the Pot wiper as per the diagram that is on here) - This means the cable connecting between PWM and IN is quite long (as it runs to the switch and back) Not sure if noise on this could cause an issue.

When it connects to LB there is an error 9 at the start but after that doesn't seem to cause issues work. Is there anything else I can try? I have a basic scope so can probe around with that although not sure what to look for? I am not totally ruling out software at this stage but the nature of the freeze up is very odd.

It's all getting a bit frustrating now - when it happens it will spoil a job so regrettably I think we may have look start considering other board options as we are very happy with Lightburn.

Any help would be greatly appreciated thanks again.

This issue is often caused by ground loop currents which flow back through the USB cable which it is no supposed to do. Run the job without the laser head on and see if it completes. If so then definitely worth investigating the ground connection (also for your safety). See our blog https://awesome.tech/k40-laser-grounding-instructions/

Cheers, Paul awesome.tech

Forum Registration

EDIT YOUR PROFILE HERE