Please or Register to create posts and topics.

Laser power doesn't seem to adjust

Hello, I recently set up the mini grbl controller in a k40 I just purchased. Using lightburn with it, I can't seem to get the laser power to adjust at all. When engraving an image, it seems to not skip the white parts either. I've tried adjusting my min/max power and also my power on the lcd of the k40 but still seems like its always constant consistent power.

I attached an image of what I was running some start up tests with, the image and then the results. Once I saw that it was just straight filling the whole thing in I stopped and tried again at different settings. I also attached an image of my mini grbl plugs just in case it's something with that. Hoping someone might have some better insight 🙂

A few other things I've attempted to make it work:

  • Checked my lense to substrate distance
  • adjusting various speeds and power on LB and Power panel
  • switching from image to line and fill
  • drinking a beer
  • trying different woods
  • various $ settings from

Thanks for taking a look!


Here are my $ settings:









(ATC M6, pulse/ff)


(ATC Tool Td, milliseconds)


(ATC M6 Td, milliseconds)






(Softstart, milliseconds)










(Spindle freq. 0 to 15)



































(x:mm max)


(y:mm max)


(z:mm max)


(a:mm max)


(b:mm max)

Uploaded files:
  • IMG-1880.JPG
  • IMG-1879.JPG
  • IMG-1881.JPG
  • IMG-1878.JPG

You don't have the PWM pin wired to the IN pin on the PS.  That's what's used to vary the power and enable gray scale.

Also you might double check what the bundle of white wires you have connected there on the center connector of the mini gerbil.  I believe that's an alternate limit switch connector but looks like what is coming from your 2nd connector on the PS?


Hi @maxd,

@humptydumpty has it right, the last pin on the top right corner of your Mini Gerbil photo needs to be connected - it's what is controlling the laser beam power.



Forum Registration