EDIT YOUR PROFILE HERE

You need to log in to create posts and topics.

Laser not shutting off on moves

Having a problem with my laser not shutting off between white scan when doing a vector engrave. I wil post pics and my settings on K40. I did change the setting back to default that is posted on the awsome tech website still the problem is happening.

$0=10 (Step pulse time, microseconds)
$1=255 (Step idle delay, milliseconds)
$2=0 (Step pulse invert, mask)
$3=1 (Step direction invert, mask)
$4=0 (Invert step enable pin, boolean)
$5=1 (Invert limit pins, boolean)
$6=0 (Invert probe pin, boolean)
$7=0 (ATC M6, pulse/ff , just for CNC )
$8=100 (ATC Tool Td, milliseconds just for CNC )
$9=100 (ATC M6 Td, milliseconds, just for CNC)
$10=1 (Status report options, mask, used to be 31 to show all info)
$11=0.010 (Junction deviation, millimeters)
$12=0.002 (Arc tolerance, millimeters)
$13=0 (Report in inches, boolean)
$19=0 (Softstart, milliseconds, just for CNC spindles)
$20=0 (Soft limits enable, boolean)
$21=0 (Hard limits enable, boolean)
$22=1 (Homing cycle enable, boolean)
$23=3 (Homing direction invert, mask)
$24=2000.000 (Homing locate feed rate, mm/min)
$25=2000.000 (Homing search seek rate, mm/min)
$26=250 (Homing switch debounce delay, milliseconds)
$27=2.500 (Homing switch pull-off distance, millimeters)
$28=5 (Spindle freq. 0 to 15) – 5 = 1.5kHz
$30=1000 (Maximum spindle speed, RPM)
$31=1 (Minimum spindle speed, RPM)
$32=1 (Laser-mode enable, boolean)
$100=157.000 (X-axis travel resolution, step/mm)
(x:stp/mm)
$101=157.000 (Y-axis travel resolution, step/mm)
(y:stp/mm)
$102=160.000 (Z-axis travel resolution, step/mm)
(z:stp/mm)
$103=160.000 (a:stp/mm)
$104=160.000 (b:stp/mm)
$110=12000.000 (X-axis maximum rate, mm/min)
(x:mm/min)
$111=5000.000 (Y-axis maximum rate, mm/min)
(y:mm/min)
$112=5000.000 (Z-axis maximum rate, mm/min)
(z:mm/min)
$113=5000.000 (a:mm/min)
$114=5000.000 (b:mm/min)
$120=8000.000 (X-axis acceleration, mm/sec^2)
(x:mm/s^2)
$121=3000.000 (Y-axis acceleration, mm/sec^2)
(y:mm/s^2)
$122=3000.000 (Z-axis acceleration, mm/sec^2)
(z:mm/s^2)
$123=3000.000 (a:mm/s^2)
$124=3000.000 (b:mm/s^2)
$130=320.000 (X-axis maximum travel, millimeters)
(x:mm max)
$131=230.000 (Y-axis maximum travel, millimeters)
(y:mm max)
$132=200.000 (Z-axis maximum travel, millimeters)
(z:mm max)
$133=200.000 (a:mm max)
$134=200.000 (b:mm max)

Uploaded files:
  • IMG_9650.JPG
  • file.png
These artefacts happen when the LO laser on signal has some resistance e.g. bad connection. Lightburn does not turn off the LO signal between travels (M5 commands) but just use the S0 commands for speed reasons.
You can test this out by setting the laser in CNC mode so you can switch on the laser without motion and issuing a few power commands.
$32=0
M4 S0
Don't forget to set the laser back to laser mode via $32=1 when you're finished.
These G-code commands turns on the laser with zero output (S0). If you hear the power supply or tube hissing then it is lasering (or check the tube compartment to inspect the glow within the tube). Note: be careful - laser protection and don't touch high voltage parts).
Switch of the machine and re-seat the power connector on the Mini Gerbil (straight) and re test. You might need to check the power connection on the K40 too.
Uploaded files:
  • MGpowerterminals.PNG
Cheers, Paul awesome.tech

I did what you suggested i took all wiring apart checked the crimps re-crimped a few wires now its working great.

Thanks

Forum Registration

EDIT YOUR PROFILE HERE