Please or Register to create posts and topics.

Inherited a k40 custom laser with an awesome tech. Have some limit switch issues to start.

I previously had a k40 with an awesome tech mini grbl that was working fine on lightburn.

So now just got my hands on a custom ortur/k40 hybrid machine that has a 40 watt tube. It came with an awesome tech mini grbl v2.0.

I know it did work years ago so I’m trying to get it going again. Currently my first issue is getting the machine to stop once it hits the limit switch’s. From what I can see they are connected to the board in the right spot.

I have it setup on MiniGerbil STM and auto home in lightburn but it hits the home area and keeps going skipping on the belt

I’m kinda familiar with Marlin f/w and I know they have a way to show the limit switch statues. Is there a way to do this on the awesome tech boards with mini grbl? Aka physically enable the switch’s and see if the console on light burn shows it’s enabled and verify it??



Uploaded files:
  • F7C9AFFE-D892-4FE9-88F8-7000407EB14A.jpeg

Forum Registration