You need to log in to create posts and topics.

Homing not working correct

Strange issue in homing on my Mini Gerbil. Might be easier to watch the video I recorded:


Essentially, once it hits the Y axis limit switch, it stops moving towards the X limit and does it's little bounce thingy. If I start the head closer to the X limit than the Y, it will hit the X switch and then continue along the Y as expected.

As I noted in the video, I'm not sure if this behavior is the Mini Gerbil or the software (Lightburn). Anyone have a similar issue?

Hi Lee,

I have tested this on my machine with positioning Y close to the Y limit and X far away from it X limit switch. Fortunately it does home correctly so you must has an issue with your specific set up. It might be possible that the Y limit pulls the voltage down tricking the X limit input to be zero for a fraction of time. Another option is cross talk or a bad connection.

I would suggest to invest a bit of time in the connection. Is it ribbon or just plugs for the limits?

Cheers, Paul

Cheers, Paul awesome.tech


Thank you for your reply. I don't know if you saw the video, it turns out the link was bad. I have shared the source here in case you haven't:


I do that because I find the issue a bit hard to describe, and the video shows the actions clearly. I'm pretty sure you know what I'm talking about though from your description.

I have the individual wire type and not the ribbon connection. Just to check and make sure, I make a little discrete harness to test with and I have ruled out the wiring as a cause. If there is an issue it's gotta be focused on the board or the firmware I think, otherwise the control software. I was able to find out my board is running grbl 1.1f, but I'm not sure if the Mini is a custom source that may be worth updating or not.

I think my next easiest step is probably to try a different piece of software. What other control software is popular with this community?

Hi Lee,

Thanks for the video which gave me another clue with regards to the pull off parameter. I see you have mechanical limit switches so normally you need a $27 pull off distance of 4 mm.

You can use UGS or CNCjs which are free G code senders and great tools to debug. IF the pull off increase does not help than there is some cross talk causing the issue. You can add a 100nF capacitor parallel to the X-Y axis switches to damp any noise and reroute the limit switch wiring.

You can try to increase the switch bouncing delay (e.g. 350) in the $ settings see https://awesome.tech/what-are-settings/

$26=250 (Homing switch debounce delay, milliseconds)
$27=2.500 (Homing switch pull-off distance, millimeters)

The little bouncing dance at home you see is Grbl verifying the position to minimise the home location error.

Cheers, Paul

Cheers, Paul awesome.tech

Forum Registration