EDIT YOUR PROFILE HERE

You need to log in to create posts and topics.

Higher Laser Power setting causing stepper motors to loose steps

I have a legacy grbl controller with GRBL 1.1e hooked up to a k40 using lightburn to send g-code.

I noticed that the stepper motors make a louder nose when moving while burning as opposed to when making the same moves when not burning. Same code, same moments. That doesn't seem good.

Running at 20% (the lowest I can get the laser to trigger) everything runs fine.
I am ruining a Cut mode at 2000 mm/sec and a Scan Mode as high as 6000 mm/sec, no problem.

Going up to 30% on cut mode at 2000 mm/sec and suddenly the Y stepper is loosing steps. Making that awful "clunk" noise and losing steps and dropping off off track.
The way it was shuddering and stalling , it is almost like it is physically jamming? But it was moving smoothly moments before.
I am not sure what is going on.

I tried upping the current on the stepper driver just a bit but that didn't seem to have an effect.

My best guess is that firing the laser at the higher power is putting out some sort of interference???

I have the steppers 24v input on a separate 24v power supply. Both power supplies have a case ground. So I am not sure how this would be happening.

I am not confident the laser power supply is putting put good 5v, especially when firing.
So maybe it has something to do with that?
Is there a jumper on the legacy board to pull power from the USB?
I saw there were a few jumpers but don't know what they are for.

Any advice would be appreciated.

I speculate that it is related to pushing to 8 bit controller too hard on speed. Maybe try to half the speed and see if it is still showing these symptoms? It is possible to run the board of the USB power, I just have to look it up since it has been a while that we sold the legacy boards 🙂

Cheers Paul

Cheers, Paul awesome.tech

Thanks for looking it up for me.

I threw a meter on it. The 5v supply is actual around 4.7 and the and ground between the power supplies is rock sold, but between the case and power supplies not so good.

So I pulled the grounding lug. Dremmeled off the paint from the case and re-seated everything for a much better case ground connection.

I ran some quick cut tests 2000 mm/sec at 40 power. The stepper motors were louder and a different pitch but no stalling or missed steps. So the cleaner case ground made a difference. Maybe EMF from the fly back transformer? I don't know. I may try to add some shielding if it keeps acting up.

I will do a batch of test cuts at different speeds and power settings and see. But hope this fixes it.

Long term I definitely need to upgrade the controller. But I was hoping to get this one working till the new SD card version comes out. 😉

Forum Registration

EDIT YOUR PROFILE HERE