Please or Register to create posts and topics.

Help with installation

Hello all. Very frustrating problem I am having...

Installed boards according to the setup on this site, everything looks good, powers on well. However, once powered up and connected to cncjs I get no movement, no laser fire, no commands are taken or anything at all really. Jog buttons are even greyed out. I just get locked up stepper motors and the hum of the power supply.

I have seen online that you should receive a few lines from the grbl control in the cncjs console however I do not get anything but the cncjs version number.

I uploaded one of the sample gcode roasters into cncjs to see if it would attempt to run that, but it still just sits there.

Any ideas what I have done wrong? Thanks in advance for all help.

Maybe I stating the obvious but did you refresh the port selection and did it state something like ‘ftdicom1’? Also you need to select a baudrate of 115200 and click on connect. Once you do this, the black command screen would show the wake up message grbl v1.1e

if you cannot see any of the comm port info then the driver is not installed or the usb cable does not work proper (e.g. just a charger cable and not a true comms cable). The ftdi driver can be downloaded from the ftdi.org site (ftdi231x) Let us know if you got any further.

Cheers, Paul awesome.tech

Thanks for the fast reply!

Yes, I refreshed the ports, I get a successful connection through Com port 3. I might mention that the ftdi drivers do not seem to work on my windows 10 laptop. I am using an acer aspire switch 10, which is a windows tablet/laptop and when I try to install the ftdi drivers, it usually either crashes the laptop or I lose the lower halfs keyboard/ mouse function and I never could get a successful vcom port. My solution was to buy a com port adapter and neck it back down to the micro USB for the k40 control board using the drivers that came with the cables. I am assuming that could be part of the issue? I was hoping not, since it does see the com port and open it.


I do get the black console screen, just no wake up from grbl, and absolutely nothing else.




Is there a way to compare, like using or borrowing someone's laptop (different brand/specs) and use with/without the comm port adapter, so you know for sure that the adapter does not cause another issue?

You can use zadig,exe to install drivers when Windows does not want to load them. I had this issue for my USBasp programmer that I bought from eBay. Just google zadig and try one of the three drivers.

Alternatively, if you happen to have an old usb cable, you can add in the signal lines an addition resistor of 100 or 150 ohm. Some PC/Laptop USB Hub controllers are sensitive when it comes to usb devices. Which wires? Usually the red and black are the power so the remaining two wires are the signal wires. If the cable has only two wires then it is just a charger cable and will never work for communication. (Yes I came across one at home)

It's a far stretch but you can try when everything else fails. Keep me posted.

Cheers, Paul awesome.tech

Zadig.exe can be found here https://zadig.akeo.ie/

Cheers, Paul awesome.tech

It works!


So the issue definitely was the USB adapter cables. I had wiped my laptop a few times during previous driver installs, due to the crashes and loss of function on the keyboard, so that may have had something to do with it also. I just downloaded the ftdi USB drivers using the exe application link on the right of the download page. Once I ran the exe I used a micro USB cable that I had on my Razer gaming mouse, and it just connected right to it. I got the jog function, and even ran the sample raster I'll attach because it turned out well.

My only two issues now are the focus on the laser and my Y axis homes in the wrong direction. Any help with the Y axis would be awesome.


Just wanted to say thank you in closing, not only for your quick responses and help,  but so far I love this setup a thousand times more than the last retrofit I tried. Definitely "awesome tech". Thanks!

Uploaded files:
  • 20180518_113355.jpg

You can turn the direction of the Y axis via $3. Send via a g-code sender $3=2 which inverts the Y axis or alternatively you can swap the Y axis connector around.

glad it worked out! Try if you can do greyscale engavings as explained in the installation guide and potentially set the $30 (power range) which sets the grey scale range for your laser (we call the procedure calibration, so you might want to browse to some of my blogs on awesome.tech 🙂 )

Cheers, Paul awesome.tech

The focus of the lens is 50.2mm so measure it with a ruler or make a block exactly 50.2 high. Make sure that the flat side of the lens (it does not reflect your image when you look at the surfave) faces the work piece and the concave side (yes you see your  reflection) faces the incoming laser beam. Most focus problems are related to an erroneous lens install. Good luck and post some engravings and laser cuts!

Cheers, Paul awesome.tech

Forum Registration