Please or Register to create posts and topics.

Error 9 , need more information about the G-code Lock

Error 9 , need more information about the G-code Lock

(UPDATE1: Alarm 3 seems to be the start of all this.   Also seems not to create the alarm if I do not have the laser active during the run. Still need some responses to help point me in direction to find the problem.)

(UPDATE2: Checked the Stepper motor driver voltage. 0.236vdc on both, read some and up them to 0.340vdc. Still no change.)

To start, been using the mini gerbil for couple of months with Lightburn. Been working great till today.

I am now receiving an error 9. The error 9 comes in the middle of jobs. Lightburn still talks to the board. (I can do a home function and restart the process)

I checked the wiring. Twice and even rewired the grounds.

Is the mini gerbil board open inputs causing the error? Even wired the Abort/resume/Hold inputs. Still the same issue.

Could it be power? Tried both the ext 5v and USB 5v, same issue.

Thoughts  on what causes of the error 9?

Please ask any questions that might help you answer my problem.

Thanks in advanced for your time and help.


Hi, G-lock code errors are the most difficult ones. Basically the G-code being streamed has an error from which the controller cannot recover. It is not a hardware fault but a semantic or software streaming error. https://awesometech1.wpengine.com/gerbils-alarm-error-and-option-codes/

You can run the code via the command $C which is the check mode without actual execution and see where (line number) the controller stops and investigate.

This error happens for example when the arc is too small like 0.01 mm radius.

You can send me the file as a zip file and I can have a look if you want.

Solution to this can be various: fix the error line (e.g. arc radius  0.001 mm is beyond the accuracy of the controller), decrease the resolution, re-import the file at a different dpi, change the cutting format or re-draw the offending line in the design program etc. It's a rare error and annoying but you can even change the $ config settings e.g. $11 and $12 to see if that helps.

Hope this helps,

Cheers, Paul

Cheers, Paul awesome.tech

Thanks for the response.

Not sure it is a file issue. I tested most of the files I have been burning the last few weeks and they all come to the same result. Alarm 3 once the laser is engage.

Even just made a 30mm square  in lightburn and tried vector burning it(30 mm/s). Once the laser is to engage and burn the square, alarm 3 comes up.

If I try to do the same square with out letting the laser power up it moves the laser head through the square and heads home. (Same result with my other files.) No alarms or errors.

So I am thinking my laser power supply is damaged and the power is fluctuating or becomes very noisy  when the laser fires up and causing the mini gerbil a issue.

Tomorrow will try a external 24 volts supply and run the board from a usb hub.



P.S Added one of the files I was attempting to cut. Have cut this one about 5 times in the last couple of weeks.

Uploaded files:
  • gear-figit-V4.svg

Well, tested with external power supply for the 24 volt and the same thing happened.

When trying to cut a file it stops as soon as the laser is fired. If I cut the file with the laser disengaged it works fine.

Thoughts on why it may cause the alarm 3 when it fires the laser?

Did try the $C on the files I used, and there was no errors.

Reinstalled the original board and I was back in the business of cutting.

Have not given up on the mini gerbil yet, going to wait for a new laser power supply and try again with it then.

My next thoughts are the LO (laser control) wire is causing feed back. What are your thought on this? Correct me if I am wrong, the LO is tied low the laser is to fire.




Have replaced the main laser power supply, no luck. Still stops in various parts of the file. Again a simple burn, a square and circle. Once the laser goes to fire it stops.  Errors are from board halted the process to door open to ......almost each time it stops the proccess it is a different error. Have powered board from a the laser supply, usb hub, and external 5 volt supply. Same things happen.

So after reading through somemore forums have found a post about filtering the PWM by using a 0.1uf cap/50volts and a 1 kohm resistor. It as unclear on if the filter is for laser power side or the mini Gerbil side. Tried the laser side last night, no luck. Will try the mini gerbil side tonight. Will draw up a picture of what I mean and post it later.


Uploaded files:
  • PWM-Filter-diagram.svg

Well, still have the same issues. Tried filter both ways. Getting door open alarm with it. Getting very tired of this.  Have ground the safety door input (caused the alarm of check door), and then tied high. Still the system gived me a check door once the laser engages.

Found someone with k40 in my area and we tried the mini gerbil on his machine, same issue, when the laser fires the system stops. Somehow my mini gerbil board is not handling laser firing.


Thanks for your time.

Hi, Just let me know the order and I will replace it under warranty.

Cheers, Paul awesome.tech

Forum Registration