Please or Register to create posts and topics.

Driver update

Page 1 of 2Next

Just finished installing the mini gerbil on my neighbor's machine and wanted to point out that the driver will most likely need to be updated.  On a Windows 8 machine (and I am sure Windows 10 will be the same) tell windows to find an appropriate driver and all should be good.  The driver that will be install has an advanced tab in the properties where you can adjust buffer speeds in case you are having trouble connecting - I did not have that problem, but make sure you change the baud rate - it is 9600 after the update so I set it to 115200,


Make sure the Y axis plug is properly oriented.  On the machine I was hooking up, I had it in backwards at first and the Y axis was not moving - rotated it 180 degrees and all was fine.


The usb port has been upgraded to a sturdier one and you will need one of those older style usb cords.  If you are like me, you most likely have a dozen or 2 of those sitting in a box somewhere.

Another thing I noticed was that the machine is doing a slow soft home at power on - something that was not happening with my old gerbil.  Not a problem but something to be aware of - probably a $ setting that I have not looked at yet.  GRBL version is 1.1f now which is good news.


The acrylic case cover would not close on the mini because 1 of the components stuck up too high and one of the nuts was more trouble than value to get on - the one under the stepper drivers so I skipped it.  I could have cut a slit in the cover to allow it to drop all the way down but that can wait for another day.


Tested the board with Lightburn and Inkscape and both worked.  Lightburn ran faster than the Inkscape plugin mostly because of the way it bypasses whitespace.  I didn't have much time to play with various settings in the plugins but I suspect that the whitespace acceleration can be increased a lot to speed things up.


All things considered the install went well and the machine is running well.  My mini is about a week to arrival and that's when I will look at the $ settings and I will update this with my settings and observations for those who might be interested.

Hi Dave, great write up!

Some tips here: I suggest to change the baud rate to 230,400 to remove the USB comms bottle neck for engraving speed. In LightBurn you use Device Settings.

In settings use the 'mm/min' instead of 'mm/sec' setting since that seems to perform much better. Use a 'dpi' to match the picture. A 96dpi picture engraving on 600 dpi will not work well because of the software translation overhead and have little gains. Better to select something like 200 dpi.

The T220 / Mosfet component can be bent forward to allow the lid to close. Ideally you mount the pcb to the bottom plate first and then assemble the sides/lid of the case. That allows easy access to insert screws and spacers.

The slow homing is to increase the accuracy and repeat-ability of the home position. I'll look into that to see if that can be improved.

Let me know when your mini Gerbil arrives!



Cheers, Paul awesome.tech


Would you be willing to post your $ settings on the mini-Gerbil with LightBurn? I have it working, but still get some glitches occasionally and am trying to track down the cause. My issues are specificity with Y axis movement which sometimes doesn't move correctly.




These are the $$ factory settings. You can tune the Y axis feed rate a bit more via $111 since the belt on our test machine is a bit old so these are very conservative settings.

$0 = 10    (Step pulse time, microseconds)

$1 = 255    (Step idle delay, milliseconds)

$2 = 0    (Step pulse invert, mask)

$3 = 1    (Step direction invert, mask)

$4 = 0    (Invert step enable pin, boolean)

$5 = 1    (Invert limit pins, boolean)

$6 = 0    (Invert probe pin, boolean)

$10 = 31    (Status report options, mask)

$11 = 0.010    (Junction deviation, millimeters)

$12 = 0.002    (Arc tolerance, millimeters)

$13 = 0    (Report in inches, boolean)

$20 = 0    (Soft limits enable, boolean)

$21 = 0    (Hard limits enable, boolean)

$22 = 1    (Homing cycle enable, boolean)

$23 = 3    (Homing direction invert, mask)

$24 = 2000.000    (Homing locate feed rate, mm/min)

$25 = 2000.000    (Homing search seek rate, mm/min)

$26 = 250    (Homing switch debounce delay, milliseconds)

$27 = 2.500    (Homing switch pull-off distance, millimeters)

$28 = 5    (Spindle freq. 0 to 15)

$30 = 1000    (Maximum spindle speed, RPM)

$31 = 1    (Minimum spindle speed, RPM)

$32 = 1    (Laser-mode enable, boolean)

$100 = 157.000    (X-axis travel resolution, step/mm)

$101 = 157.000    (Y-axis travel resolution, step/mm)

$102 = 160.000    (Z-axis travel resolution, step/mm)

$103 = 160.000   (a:stp/mm)

$104 = 160.000   (b:stp/mm)

$110 = 12000.000    (X-axis maximum rate, mm/min)

$111 = 5000.000    (Y-axis maximum rate, mm/min)

$112 = 5000.000    (Z-axis maximum rate, mm/min)

$113 = 5000.000    (a:mm/min)

$114 = 5000.000    (b:mm/min)

$120 = 8000.000    (X-axis acceleration, mm/sec^2)

$121 = 3000.000    (Y-axis acceleration, mm/sec^2)

$122 = 3000.000    (Z-axis acceleration, mm/sec^2)

$123 = 3000.000    (a:mm/s^2)

$124 = 3000.000   (b:mm/s^2)

$130 = 230.000    (X-axis maximum travel, millimeters)

$131 = 320.000    (Y-axis maximum travel, millimeters)

$132 = 200.000    (Z-axis maximum travel, millimeters)

$133 = 200.000   (a:mm max)

$134 = 200.000   (b:mm max)

This blog tells you a bit more about the LightBurn settings:


Enjoy !

Cheers, Paul awesome.tech

My mini gerbil is scheduled to arrive tomorrow and I should have it installed and tuned by Wednesday at which time I will be sharing my experiences.

Paul has reacted to this post.


I am wondering if I might be getting some noise from the 24V laser supply, resulting in some random glitches. Can the mini-Gerbil board power be moved to the power from by USB position without any issues?

My mini gerbil arrived last evening but I didn't get around to installing it until this morning.  This time I managed to get all of the nuts on the 4 screws holding the board - needle nose pliers helped a lot.  Bent the mosfet over to clear the lid and all was well.

In reviewing the $ parms I noticed that the $130 and $131 values were reversed - at least for my machine so I reset those to 320 and 240 respectively.  Other than that, I have not had to change any other settings (yet) and I am able to run an old gcode file in Lightburn that I created with Inkscape and it zipped thru it easily.

The driver that is assigned in Windows 10 has a maximum baud rate of 128,000 so I left it at 115,200 for now.  I changed the baud rate in Lightburn to 230,400 and it runs but I don't know if that made any difference in speed.  I will test Inkscape next but for now, here are my settings.
















(ATC M6, pulse/ff)




(ATC Tool Td, milliseconds)




(ATC M6 Td, milliseconds)












(Softstart, milliseconds)




















(Spindle freq. 0 to 15)






































































(x:mm max)




(y:mm max)




(z:mm max)




(a:mm max)




(b:mm max)

Well, my Inkscape testing is on hold - I've apparently messed up my Inkscape install so it won't talk to the mini.  I think it is the python serial part so I have some poking around to do.  At least I can print the gcode in Lightburn until I get this fixed.

Paul, quite a while ago you showed a link concerning how to set up pyserial for Inkscape.  I can't seem to find that link and I am pretty sure pyserial is what's causing me fits with the plugins.


With the mini-gerbil addins, I had an issue with svgpathtools library being required, but not installed on the inkscape python install. Check out the https://awesometech1.wpengine.com/k40-forum/topic/inkscapes-python-gives-you-issues/ thread to see how I resolved it in my case.


paradug - Thanks, I saw that a while ago and I will address that eventually, but I am engraving not cutting so I don't think that is my present issue.  I only cut with the laser on my CNC because I don't like to drive my CO2 that hard - preserves tube life.


Paul, when I run streamer I get this message - any idea what it means?

C:\Users\dave\Documents\LASER FILES\Gerbil\gcode>streamer.py shot.txt com5
Initializing grbl...
Traceback (most recent call last):
File "C:\Users\dave\Documents\LASER FILES\Gerbil\gcode\streamer.py", line 86, in <module>
File "C:\Users\dave\AppData\Roaming\Python\Python37\site-packages\serial\serialwin32.py", line 308, in write
data = to_bytes(data)
File "C:\Users\dave\AppData\Roaming\Python\Python37\site-packages\serial\serialutil.py", line 63, in to_bytes
raise TypeError('unicode strings are not supported, please encode to bytes: {!r}'.format(seq))
TypeError: unicode strings are not supported, please encode to bytes: '\r\n\r\n'


Also, python goes to sleep when I run the raster2engrave plugin which is why I think my problem is with pyserial.

Hi Dave, yes this message "serialwin32.py" in the error description above says it all. Not sure if the next story is going to help but I bought on advice from Dan a brand new lenovo i5 WIN10 64 bits laptop to test the installations from scratch and to see if that would throw any errors that customers would see. Incredibly it installed Inkscape 0.92.3 (64 bits) without any issues and I did not had to install serial py. Also the usb driver was detected automatically so it was a breeze. I also installed Lightburn, laserweb, CNCjs and UGS on this machine without anything else to keep it as clean as possible.

I would suggest to remove the old Inkscape and install a new one from scratch https://inkscape.org/release/0.92.3/windows/.  All plugins are available and I suggest to use the one (mini gerbil plugins) without the svg.paths (does a sequence of inner and outer cuts) since that is tricky and not working exactly as expected.  When I have time I will investigate that svg paths a bit further.

It's very rare that a usb is not detected. However if your usb driver is not automatically detected than download the virtual com driver from ST.com (VCOM) or if you are on Win7 or earlier then use the legacy driver https://www.st.com/en/development-tools/stsw-stm32102.html




Cheers, Paul awesome.tech

I have cleaned all versions of python and Inkscape off my computer and installed Inkscape 92.3 with just the plugins from the mini gerbil install (I noticed the only change to the raster2laser is the addition of the M30).  Pythonw still goes to sleep.  Lightburn has been working throughout all of this so I am sure I have a python issue.  Cleared any reference to python in the environment variables and no change.  I see that serial is in the Inkscape python2.7 site packages folder.  I eventually updated the driver to the STM flavor (although they say on the download site that Windows 10 driver is as good as their's) and still no luck - pythonw still sleeps but Lightburn works fine as does CNCjs.

Inkscape does run the extensions and I get the appropriate output files from the extension - it just doesn't feed to the K40.  I can run the output gcode in Lightburn fine.

Hi Dave, that is very strange while my new PC had no issues with the Inkscape.  You might be able to change the baudrate in the python raster engraving script to a different rate and see if that is of any help. What version OS do you have, 32 or 64 bits? I installed the 64 bits version since the new laptop has a 64 bits OS.

Another possible suggestion is to run Inkscape as a Admin or user with admin rights. Sometimes those privileges can get mixed up.

How do you find LightBurn? Ensure you change the baudrate in LightBurn too, so you get the best out of it.

Cheers, Paul awesome.tech

I have Windows 10 64 bit at the latest fix level.  The machine is a desktop and it is about 7 years old but it still runs well.

I have been using Lightburn since shortly after I got my first gerbil from you and I like it.  They have been adding feature and function steadily and it is very rare to see an issue with it.  I use a suite of products to get to  a final engraving - I usually start with Gimp to clean up the raw picture and get the intensity levels where I want them, then off to Inkscape to further enhance and either burn directly or export a .png for lightburn.  Each product has it's uses and drawbacks, for instance, I prefer Inkscape for combining text with an image for a sign but I like to burn the sign in Lightburn because it is faster.

I turned on verbose in the raster script and it created the log file but it appears to hang up before anything was written to it.  I will tinker with that some more to try to drill down to the root problem.  I see in the registry that there is a serial modem on COM3 and the mini is on COM4 and there is an odd looking entry that shows as unassigned so I am trying to get the script to tell me which COM port it is finding, if any.  Looking at "hard coding" the port in the script as well to see if that works.

Page 1 of 2Next

Forum Registration