Please or Register to create posts and topics.

Door, random job stops (SOLVED)

Recently getting random job stops...

Door errors (no safety interlocks installed)

Usb disconnects

LightBurn hangs

If I disconnect the PWM wire or turn off the laser the job does not error out.

Why would it continue perfectly without the PWM wire?

Possible fixes I am or have tried:

Ground (checked and rechecked)

New shielded cables for motors/interlocks (coming Tuesday Feb. 2nd)

EMI Filter (Tuesday)

Hardcore USB cable (Tuesday, tried a few I had around with no change) *THIS FIXED IT*

Powered USB hub (installed no change)

I will update anyone when/if a fix is found... Seems like it is common enough, but no concrete answers in forum/online.

If anyone has a fix please let me know...


















Hi, try to run a job without the laser  fire button pressed, so it does not fire . What are the results than? Cheers Paul

Cheers, Paul awesome.tech

Why would it continue perfectly without the PWM wire?--> I think this should not be possible. Check whether there are more than one wire going into the IN terminal at the k40 power supply. If not, maybe a defect Power supply?

Best to post some photos as well.

Cheers Paul

Cheers, Paul awesome.tech

It does run without the PWM wire just runs like it's in cnc mode (lines between)

Without the fire button on it doesn't fire but runs fine with no interruptions.

I took some pictures and videos (may have a swear word or three)


It was printing well for a bit then started some shenanigans... ( I need to upgrade the power supply, this is the original).

The PWM wire is temp until I receive some jumpers on Tuesday ( I was moving the gerbil to reduce EMI).

I ordered a bunch of 2.54 pitch connectors to rerun the wires. Is that the correct pitch?

Thanks for your time!!!

2.54 pitch is correct.  Btw try to set the hard limits $21=0 and see if that makes a difference.  A customer pointed out to us that he encountered the same issue when setting hard limits in the $ settings

Cheers, Paul awesome.tech


$21=0 is correct in my settings. No change needed.



Okay it seems to me that there must be some interference e.g. bad grounding or HT lead close to other wires or the board has a defect. Give us an email on support@awesome.tech to see if we can sort it out.

Cheers, Paul awesome.tech

Thanks Paul,


New USB cable came today and I am having NO ISSUES what so ever...


I still plan on changing out the wires and adding the EMI Filter...

Changed the EMI Filter today.


Just wanted to reiterate that all was fixed with the USB CABLE.

Not sure what could have happened to the old one but as soon as it was swapped out I have not had one problem.

Paul has reacted to this post.

Forum Registration