Please or Register to create posts and topics.

cuts but no engrave

The setup:

gerbal proset

I7 labtop windows 10, same problems 2 different computers

inkscape .62.0 32bit

pot removed, saw no need to power bypassed device

CNCjs moves gantries to all positions and homes.



Cuts most of the time. Sometimes needs to be rehomed because it stops always at the same place on y axis and locks up inkscape.

Black and white raster prints a few black lines and either hangs inscape or homes.

Grey scale always locks up inkscape.

Hangs have caused laser to stay on in one spot - started a fire one time. One time cutting went to full power, Sometimes laser stays on while homing


Tried different computers, tried different usb cords - ordered a shielded cord

Tried both usb2 and 3 ports

Tried original and both raster betas

Tried several inkscape builds, settled on 32 bit .62 after seeing post.

pulled ground and 5v line when removing pot so no grounding there.

May put cap on y limit switch to see if it fixes homing problem but I think it is more a software issue. could get CNCjs to hang but I had to work hard to do it.


Buy 4000w cutter to slice k40 into little pieces? Opps cutter bought for wife better not.

Also may make a separate circuit to kill laser power if usb coms go silent.

I would like to promote the K40 and gerbal to our college maker lab and students but have some concerns after this experience, any ideas.


Sheilded USB cable made a huge difference. I can actually gray scale now without inkspace hanging.

Down to an issue where it prints for a couple minutes then both axies stop but the laser keep firing. I put 104 caps on both limit switches and pwm. No change, I did actually kick an error once but I have not been able to repeat it. Not 100% sure its related.

Traceback (most recent call last):

File "raster2laser_gcode.py", line 762, in <module>


File "raster2laser_gcode.py", line 757, in _main


File "C:\Program Files (x86)\Inkscape\share\extensions\inkex.py", line 283, in affect


File "raster2laser_gcode.py", line 176, in effect


File "raster2laser_gcode.py", line 648, in GcodetoController

log.write("\n Error rate "+ str(error_count))

UnboundLocalError: local variable 'log' referenced before assignment

Hi Gregg,

that error refers to a communication error. Please can you download the latest engraving plugin since I catch the errors a bit better. The beta3 can be downloaded from the download menu on the home page.

i speculate that the usb mini b plug does not fit nicely into the Gerbil usb port. Some usb cable don’t fit well in the receptacle. It seems there are many different toleraces between vendors of usb cables and connectors. This explains why Gerbil sometimes stops in the middle of the task. It lost its connection. Let me know how you go with a few different cables, cheers Paul

Cheers, Paul awesome.tech

Tried 9 cables. I went to extend the timeout in the .py file but see you changed that to 2 already. On one of the cables the speed slowed for a few passes then got the com error. I am going to keep trying some things and I will post the results.

Slowing down the baud rate on the gerbil.

Is there a way to drop the baud rate on the controller short of editing serial.c and recompiling?

Since there seems to be an issue with microB cables, slowing down to data flow may help with the issue.


I was having these same problems along with other communication issuse.  I switched to Itits shielded micro USB cables in 4 foot length and I haven't had any problems since.  The vit snugle in the USB slot on both ends and don't wiggle.

Fantastic, thanks for the reference. I will order them today.

I cannot find that brand anywhere.

I got them on amazon

3 of iKits Micro USB Cable, 4ft Nylon Braided High Speed Durable Sync and Charge Cord for Android, Samsung, HTC, LG, Google & etc., Metal Plug & Mixed Color Cotton Jacket, USB 2.0 A Male to Micro B Cable

Ikits instead of Itits. Freudian slip?? Thanks for for letting me know!!!

long day and fat fingers - sorry


I had 3 more new cables come in all with very tight fits. Still getting the com errors. I am holding out for the cable that Dave uses to try but that will be 13 different cables tested. I am starting to think this may not be a cable issue. Any thoughts on dropping the baud rate? Uart issue?

Hi Gregg, the only thing that I think off is that the usb receptacle has a defect. PM me and I will arrange a replacement for you. Cheers, Paul

Cheers, Paul awesome.tech

Forum Registration