EDIT YOUR PROFILE HERE

Please or Register to create posts and topics.

connect problem

Happy New Year,
I have the problem that I can not get in touch with my Mini-Gerbil.
For over a year I have had a lot of fun on my Mini-Gerbil controller and my K40. But now I can no longer connect the controller, either with the original comuter (win7) or with a new computer with win10. I have in pure despair tampered with everything in my windows setup and that may be my problem too.
Would you please help me get back on track?
None of my computer responds when I plug in the usb cable and there are also no extra serial ports other than no.1. On the Mini-Gerbil led-nr.2 flashes quickly all the time. I have been using Lightburn since I have had the Mini-Gerbil.

Yours sincerely
Bernd

no time or no desire?

Hi Bernd, we received your support request via email, so Dan is working on it.

Cheers, Paul

Cheers, Paul awesome.tech

ohh, now I feel a little rude - sorry and thank you

Here is some extra information, on the one computer I have now installed Ubuntu 20.04 and here there is also no connection to the Mini-Gerbil controller.
But, with my Macbook and OS Big Sur, there is contact right away. My problem is just that I can not / must not use this Mac to control my laser, it must be one of the two workpcs (win7 - win10)

with best regards
Bernd

Hi Bernd,

just wondering if you've tried an alternative USB cable?

I suggest you also closely inspect the USB socket on the Mini Gerbil for damage.  Here's an example scenario: depending on how your USB cable has been positioned, and whether you flex it whenever you plug and unplug a laptop, the socket could have been put under pressure from the cable or movement.  Does it seem ok, no looseness?

Did the problem occur just suddenly and finally?  What I mean by that is that once the problem occurred once, did the system ever even temporarily work again?  If not, the problem could have been a voltage spike on your power line, such as that caused by lightning.

Are you using your K40 very frequently?

Regards,

Dan

Hey Dan,
Thanks for your reply.
I have had my Mini-Gerbil controller for almost 2 years in use with a K40 laser machine and an old but well-functioning Windows7 desktop computer. I use the laser regularly, sometimes 7 days a week. The computer and the K40 are "permanently" connected and were not moved around. But in connection with the fact that I have moved during my Christmas holiday in a slightly larger workshop, I have disconnected the laser and the computer, moved and connected everything again. I am well aware that a quality usb cable is needed and that power outages or outages can cause connection problems.  My problem is that after I tried 3 different usb cables I have assumed that my old windows computer was not in perfect working order anymore. I have because I could not see the usb connection from minigerbil in windows system tried to install stm32 driver and think it made the problem worse. I bought another computer with Win 10, 64bit, newly installed - no usb connection to my MiniGerbil either, usb mouse, and keyboard works fine and usb memory sticks are also recognized. In my desperation I have installed Ubuntu 20.04 on one comuter - it also finds no Mini-Gerbil!

BUT when I plug the cable into my Macbook pro, there is connection right away and I can produce with LightBurn.
I can and must not use Macbook in my workshop state, so it is very important for me to get life in a Windows or Ubuntu computer together with Mini-Gerbil

sorry for the long explanation I accept all suggestions and would be happy if you could guide me to a solution to the problem.

Thanks
Bernd

Hi Bernd,

you're welcome, and thanks for the clearly written history of this issue.

If you haven't already, it is critical that you follow the K40 grounding instructions at https://awesome.tech/k40-laser-grounding-instructions/. Please confirm this has been done.

If that doesn't improve things it's fair to say that your USB communications have degraded to the point where it's marginal (works with some computers and not others). Let's think through why:

You mentioned moving... the possibilities are:

* the quality of the grounding at your new workshop may not be as good as your old one. For safety's sake, please consider using a powerpoint tester, including the ground connection.

* You may also like to consider what else is plugged into the same electrical circuit breaker as your K40 and computer - any workshop or other heavy equipment (pump/motor/power supply etc). On this theme, are any of your Windows computers laptops, I wonder what happens if you run them off battery vs plug into wall...

* is it correct to say that the controller hasn't worked at the new location at all? Could it have taken a bad bump/vibration while moving to the new workshop? Vibration is the enemy of electronics!!

Which, if any, of these do you think could apply?

Regards,
Dan

Hey Dan,
Thank you so much for the time you take to help me.
Regarding the electrical earth connection, I can say that I am completely aware of this important problem and that I have a professional earth connection in all the sockets in the house, it is a legal requirement in Denmark. This also applies to the K40 itself, which I know is miserably grounded from the start and was fixed very first.

You may have overlooked this part of my last post, almost at the end, where I write that I have a nice connection to the controller with my Macbook, it's so weird and frustrating.

Can you point me to a description of how to reinstall a Mini-Gerbil Controller, either under Ubuntu or Mint or Windows 7 or Windows 10? Because in none of these machines can I see a USB connection to the Mini-Gerbil, this part of the installation will be the most important.

Another question, on your side there has been a troubleshooting chart, I can not find it anymore, will you show me where it is?

Take care of yourself and avoid the corona
Bernd

Hi Bernd,

Win10 does not require a virtual com port driver however lower versions of WIndows do need a driver.

just check with the device manager in Windows  (any version) and look under lpt,com ports, you should see VCP ST microelectronics icon (MG plugged in, Power on). An exclamation mark indicates that the driver is not working proper. Absent driver means that either the cable/plug/MG board are not working/defect or you need to install the windows driver (any version below WIN10). See https://www.st.com/en/development-tools/stsw-stm32102.html

The troubleshooting card is in the sub menu below the K40 forum menu. See https://awesome.tech/mini-gerbil-debugging/

Please let us know if you got any further.

Paul

Cheers, Paul awesome.tech

Forum Registration

EDIT YOUR PROFILE HERE